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Application note

Getting started with projects based on dual-core STM32H7 microcontrollers
in STM32CubelDE

Introduction

This application note describes how to get started with projects based on STM32H7 Series dual-core microcontrollers in the
STMicroelectronics STM32CubelDE integrated development environment.
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General information

1 General information

STM32CubelDE supports STM32 32-bit products based on the Arm® Cortex® processor.

Note: Arm is a registered trademark of Arm Limited (or its subsidiaries) in the US and/or elsewhere.

arm

1.1 Prerequisites

The following tools are prerequisites for understanding the tutorial in this document and developing an application
based on the STM32H7 Series:

. STM32CubelDE 1.4.0 or newer
. STM32Cube_FW_H7_V1.7.0 or newer
. STM32CubeMX 6.0.0 or newer

Users are advised to keep updated with the documentation evolution of the STM32H7 Series at www.st.com/en/
microcontrollers-microprocessors/stm32h7-series.html.

1.2 The use cases in this document

In the STM32CubelDE context, users have different ways to explore and get started with the development of
projects based on the STM32H7 Series. From the list below, select the description that best fits the use case
considered and refer to the corresponding section in this application note:

. | already have an SW4STM32 project with an ioc file:
Refer to Section 2.2 Import an SW4STM32 project with an ioc file
. | already have an SW4STM32 project without an ioc file:
Refer to Section 2.3 Import an SW4STM32 project without an ioc file
. | want to learn with and explore example projects:
Refer to Section 2.5 Import a project from the STM32CubeH7 MCU Package
. | want to start a first STM32H7 project:
—  Empty project — No STM32CubeMX support for maximum flexibility.
Refer to Section 2.4 Create an empty project based on the template in the STM32CubeH7 MCU
Package
—  STM32CubeH7 project — STM32CubeMX-managed project.
Refer to Section 2.1 Create a new STM32 project

1.3 Specific features of dual-core microcontrollers in the STM32H7 Series

The most obvious feature of a dual-core STM32H7 device is its significant performance boost that comes from the
addition of an Arm® Cortex®-M4 core besides the Arm® Cortex®-M7 core. Dual-core STM32H7 devices are also
very flexible. This application note is a simple getting-started guide to get up and running with a debug session
when both cores are running. It does not cover such additional features as the flexibility of being able to boot on
either core or the fact that each core can exist in an independent power domain to optimize energy consumption.

1.3.1 Dual-core STM32H7 project structure

When a dual-core STM32H7 project is created, its structure is automatically made hierarchical. The project
structure for single-core projects is flat. On the contrary, in a multi-core project, the hierarchical project structure is
used. When the user creates or imports a dual-core STM32H7 project, it consists of one root project together with
sub-projects, referred to as MCU projects, for each core.

The MCU projects are real CDT™ projects that can contain both build and debug configurations. On the contrary,
the root project is a simple container that allows sharing common code between the cores. The root project can
contain neither build nor debug configurations.
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Specific features of dual-core microcontrollers in the STM32H7 Series

3

If the project is not shown in a hierarchical structure, this can be changed as shown in Figure 1.

Figure 1. Setting the project hierarchical view
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Create and import projects

2 Create and import projects

This chapter describes how to create or import projects for dual-core microcontrollers in the STM32H7 Series.

2.1 Create a new STM32 project
To start a new project, go to [File]>[New]>[STM32 Project] as shown in Figure 2.
Figure 2. New STM32 project
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File Edit Source Refactor Navigate Search Project Run Window Help

New Alt+Shift+N > Makefile Project with Existing Code
Open File... C/C++ Project
. Open Projects from File System... = STN.BZ Project
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Convert to a C/C++ Project (Adds C/C++ Nature)
Close Ctrl+W
&% Source Folder
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3

Select the desired MCU or board. In the example illustrated in Figure 3, the selected board is the NUCLEO-
H74571-Q. Click on [Next >].

Figure 3. Target selection

[ sT™32 Project O X

Target Selection

Select STM32 target

+Board Filter:
B EO? O Features Large Picture Docs & Resources [ﬂ Datasheet [ Buy
Part Number Search ~ e NUCLEO-H745Z1-Q
Q. NUCLEOQ-HT45Z1-Q ~ STMicroelectronics NUCLEO-H745Z1-Q Board Support and Examples
Vendor N Unit Price (USS): 20.0
Active
Type > Products in mass production Mounted device: STM3ZH7457ITx
MCUMPU Series > The STM32 Nucleo-144 boards provide an affordable and flexible way for users fo try out new concepts
and build prototypes by choosing from the various combinations of performance and power consumption
Other ~ features, provided by the STM32 microcontroller. For the compatible boards, the internal or external
SMPS significantly reduces power consumption in Run mode.
Price =290 The ST Zio connector, which extends the Arduine™ Uno V3 connectivity, and the ST morpho headers
[ . provide an easy means of expanding the functionality of the Nucleo open development platform with a
- wide choice of specialized shields.
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@ p
@ Boards List: 1item & Export
g |- | oveview ] Pt | Twee | WarketingStatus | UnitPrice S5) | Mounted Devicz |
@ e
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Import an SW4STM32 project with an ioc file

After the target selection comes the project setup step shown in Figure 4. The Targeted Project Type setting
determines whether the project gets generated by STM32CubeMX or not. An Empty project is a skeleton of a
project that needs building upon while STM32Cube indicates an STM32CubeMX-managed project.

Figure 4. Projet setup

[LE STM32 Project O X

Project Setup
Setup STM32 project

Project Name: NUCLEO—H?4SZI—d
Use default location
Location: C:/Users/ /STM32CubelDE/workspace Browse...

Options
Targeted Language

®c Oc++

Targeted Binary Type
(®) Executable Static Library

Targeted Project Type
(®) STM32Cube () Empty

@ < Back Next > Einish Cancel

2.2 Import an SW4STM32 project with an ioc file

If the project already contains an ioc file, the easiest way to import the project into a working STM32CubelDE
environment is to copy it and open the copy through STM32CubeMX stand alone, then, in the Project Manager,
change the Toolchain / IDE to STM32CubelDE and regenerate the project.
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Import an SW4STM32 project without an ioc file

After the project is regenerated, go to [File]>[Import...] and choose to import it as an Existing projects into
workspace as shown in Figure 5.

Figure 5. Import an existing projet with an ioc file

m Import O X

Select H

Create new projects from an archive file or directory.

Select an import wizard:

type filter text

v = General ~
J& Archive File
1= Existing Projects into Workspace
1 File System
& Import ac6 System Workbench for STM32 Project v

Then copy the code inside the different /* USER CODE BEGIN */ blocks that exist in the project into the new
STM32CubelDE environment.

23 Import an SW4STM32 project without an ioc file

To make sure the project gets a hierarchical structure, the recommended way is to go to [File]>[New]>[STM32
Project] as shown in Figure 6.

Figure 6. New STM32 project

m workspace - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help

New Alt+Shift+N > Makefile Project with Existing Code
Open File... C/C++ Project
. Open Projects from File System... = smsz Project
Recent Files > ™ Project...
Convert to a C/C++ Project (Adds C/C++ Nature)
Close Ctrl+W
&9 Source Folder
Close All Ctrl+Shift+W | 4 Folder
Save Ctrl+S & Source File
Save As... [i" Header File
Save All Ctrl+Shift+S  [¥ File from Template
Revert @ Class
Vigwm = Other... Ctrl+N

Select the device for the project being imported and click on [Next >].
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When setting up the project as shown in , make sure the Targeted Project Type is set to Empty and click on
[Finish].

Figure 7. Projet setup

[LE STM32 Project O

Project Setup

Setup STM32 project

Project Name: | NUCLEO-H745Z1-Q
Use default location
Lozation: C:/Users/ /STM32CubelDE/workspace Browse...
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Targeted Binary Type
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Create an empty project based on the template in the STM32CubeH7 MCU Package

After the empty hierarchical project is generated:

1. Go to [File ]>[Import...]

2. Import the SW4STM32 project as Import ac6 System Workbench for STM32 Project

3. Copy and paste the project files and resources into the sub-project of the empty project as shown in Figure 8

Figure 8. Copy project content to empty sub-project

v [E NUCLEO-H74571-Q_swdstm32

> 4 Binaries

> @l Includes

> 2 CM4/Src

» & Common

> 2 Drivers

v (& startup
> [8 startup_stm32h745xx_CM4.s
> 19 startup_stm32h745xx_CM7.s

v T NUCLEO-H7457I-Q_Empty
v [E NUCLEO-H745Z1-Q_Empty CM4 (in C\VI4)
s @ Includes

> 2 Inc
» = Debug_CM4 L e s
Pl
> = Debug_CM7 / -~ = Startup
v =
(;:A:l [G STM32H745ZITX_FLASH.Id
s
ne [ STM32H745ZITX_RAM.Id
~ = Src
[& main.c

> Wl Includes

7@ NUCLEO-H745Z1-Q_Empty_CM7 (in CM7)
> @ Inc

stm32h7xx_hal_msp.c
[@ stm32h7xx_it.c

> 2 Src
v &CMT7 /'} - ot
artu
> & Inc —7 P

&5 [5 STM32H745ZITX_FLASH.Id
rc \ [ STM32H745ZITX_RAM.Id
[@ main.c

[@ stm32h7x¢_hal_msp.c

[& stm32h7xx it.c
= NUCLEO-H745Z1-Q_swdstm32 Debug.hex
[@ stm32h745xx¢_flash_CM4.1d
[@ stm32h745xx_flash_CM7.1d

m

Note: It is not recommended to import the . cproject, .project or .settings files.

It is important to remember to configure also the same build settings used previously while the project was in the
SW4STM32 environment. If the project contains linked resources, these need to be updated to point to the correct
resource in the file system.

This process is necessary because, when importing without any special treatment a project from SW4STM32 that
does not have an ioc file, it is imported into STM32CubelDE with a flat project structure.

24 Create an empty project based on the template in the STM32CubeH7 MCU
Package

Follow the same steps as in Section 2.3 Import an SW4STM32 project without an ioc file but use
STM32Cube_FW_H7 firmware in the STM32CubeH7 MCU Package as input.
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Import a project from the STM32CubeH7 MCU Package

25 Import a project from the STM32CubeH7 MCU Package

In order to import the STM32Cube firmware project into STM32CubelDE, go to [File]>[Import], select Existing
Projects into Workspace as shown in Figure 9, and click on [Next >].

Figure 9. Import of firmware project into STM32CubelDE

m Import O X

Select o

Create new projects from an archive file or directory.

Select an import wizard:

type filter text

v = General ~
J& Archive File
1 Existing Projects into Workspace
1 File System
& Import ac6 System Workbench for STM32 Project
El Import Atollic TrueSTUDIO Project v

Then select the correct project. A project example is by default located at SHOME\ STM32Cube\Repository\ST
M32Cube FW H7 VX.X.X\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO EXTI.

Figure 10. Firmware project selection

[ import O X

Import Projects @
-

Select a directory to search for existing Eclipse projects.

(®) Select root directory: | C:\Users\ \STM32Cube\Repository\STM32Cube_FW_H7_V1.5.0\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO_EXTI ~ ‘ | Browse... ‘
O Select archive file: - Browse...
Projects:
STM32H745Z1_Nucleo (C:\Users\ \STM32Cube\Repository\STM32Cube_FW_H7_V1.5.0\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO_EXTN\SW4STM32\STM32H7457|_Nucleo) Select All
Options

Search for nested projects

[ Copy projects into workspace

[ Close newly imported projects upon completion
[THide projects that already exist in the workspace
Working sets

[[J Add project to working sets

Weorking sets: i Select...

® o> ] Concel

After selecting the project, click on [Finish] to import and build the project.
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Debugging

3 Debugging

This chapter highlights some of the points to bear in mind while debugging a device in the STM32H7 Series.
In the next two sections, this application note covers the configurations needed to start debug sessions with
ST-LINK GDB server and OpenOCD.

To start configuring the launch of the debug session, right-click the sub-project (in this example, the Cortex®-M7)
and select [Debug As]>[Debug Configurations...] as shown in Figure 11.

Figure 11. ST-LINK GDB server debug configuration (1 of 6) and OpenOCD debug configuration (1 of 3)
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Copy Ctl+C IR CODE END Includes */
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Rename... F2 ate define ----------------oo -
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Build Project

R CODE END PD */
Clean Project
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R CODE BEGIN PM */

Close Project

Close Unrelated Projects R CODE END PM */

Build Configurations » pvate variables --------ooooooooooooooooo-
Build Targets b
Index >

Show in Remote Systems view

D FRunAs >
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Note: For the rest of this section, examples are based on the NUCLEO-H755ZI-Q board.
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Setting up with ST-LINK GDB server

3.1 Setting up with ST-LINK GDB server

Since the STM32CubeMX default project puts the Cortex®-M4 in the Deepsleep mode, the [Reset behaviour]
field must be set to Connect under reset to be able to communicate with the CPU (refer to Figure 12). The

Halt all cores option must not be set. Setting it prevents the Cortex®-M4 from starting to execute the code. The
Cortex®-M4 must execute the code and go to Stop mode before the Cortex®-M7 can start executing the code and
wake up the Cortex®-M4 by releasing a hardware semaphore. In the debug configuration, select Enable shared
ST-LINK, switch to the Startup tab and select [Add...].

Figure 12. ST-LINK GDB server debug configuration (2 of 6)

[T Debug Configurations m} X

Create, ge, and run fi ti

THeEXI BT - Name: | NUCLEO-H745Z1-0_CMT Debug
|typefi|tertaxt | Main Iﬁ? Debuggarl = Startup| Ep Source| B Qommon|
C/C++ Application GDB Connection Settings
C/C++ Attach to Application (®) Autostart local GDB server Host name or IP address | localhost

C/C++ Postmortemn Debugger
C/C++ Remote Application (0 Connect to remote GDB server Port number 61234

GDB Hardware Debugging
& Launch Group Debug probe |ST-LINK (ST-LINK GDB server)

~ E 5TM32 Cortex-M C/C++ Application GDB Server Command Line Options
[I] NUCLEO-H745Z1-0_CM4 Debug

[ NUCLEQ-H745Z1-Q_CM7 Debug Show Command Line

Interface

®) SWD (@)1

[]ST-LINK 5/ Scan
Frequency (kHz): | Auto v‘
Access port: | 0 - Cortex-M7 ~ ‘

Reset behaviour

Device settings

Debug in low power modes: | Enable ~ |

Suspend watchdog counters while halted: | Me configuration ~ |

Cross Trigger Interface (CTI)
[] Allow other cores to halt this core [ ] Signal halt events to other cores

Serial Wire Viewer (SWV) RTOS Kernel Awareness
[JEnable []Enable RTOS Proxy
Care Clock (MHz); 16.0 Driver settings

Limit SWO clock Driver: | ThreadX ~
Mazirum SO clack (kHz): | auto detect Port: | cortex_mil v
Fort nutrber 61235

Port nurnber: | 60000

Misc
[#] Verify flash download
Enable live expressions

[ Leg to file: C\Users\burguera\5TM32CubelDE\workspace_1.9.0.22w0\NUCLEO-H745Z1-Q\CM7\Debug\st-1| | Browse...
[ External Loader: Scan Initialize

Shared ST-LINK
[ Max halt timeout(s): 2

Revert Appl
Filter matched 9 of 11 items =43 PRy

@ Debug | ‘ Close

AN5361 - Rev 4 page 12/26




AN5361

Setting up with ST-LINK GDB server

AN5361 - Rev 4

Startup tab - Cortex®-M7

The Cortex®-M7 debug configuration is responsible for loading both the Cortex®-M7 and Cortex®-M4 images. Go
to the Startup tab to do this as shown in Figure 13:

Figure 13. ST-LINK GDB server debug configuration (3 of 6)

m Debug Configurations

Create, ge, and run c

gurations

FEEY EINEE

type filter text

1 C/C++ Application

] C/C++ Attach to Application
€] C/C++ Postmortem Debugger
[£] C/C++ Remote Application

=] GDB Hardware Debugging

& Launch Group

# Launch Group (Deprecated)

Name: ‘ NUCLEO-H755-Q_CM7 Debug

Main |°¢ Debugger | ¥ Startup %~ Source‘ £ Common

Initialization Commands

Load Image and Symbols

File Build Download Load sy...

Add..
E

~ [Z STM32 Cortex-M C/C++ Application . DeEug/NUCLEOfHYSSfocM4.e:: [NUCLEO-H755-Q_CM4] 7 true . j true Z true
[T NUCLEO-H755-Q_CM4 Debug Debug\NUCLEO-H755-Q_CM7.elf [NUCLEO-H755-Q_CMT7] See Main... true true
[E NUCLEO-H755-Q_CM7 Debug Remove
Move down
Runtime Options
[]set program counter at (hex):
Set breakpoint at:
Exception on divide by zero
[ Exception on unaligned access
Halt on exception
Resume
Run Commands
Filter matched 10 of 10 items Revert Apply
@ Debug | ‘ Close
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Setting up with ST-LINK GDB server

To download also the Cortex®-M4 image, click [Add...], browse the correct project, and build the configuration.
The result is shown in Figure 14.

Figure 14. ST-LINK GDB server debug configuration (4 of 6)

U1 Add/Edit item O X

This file is already used.

Project: NUCLEO-H755-Q_CM4 b

Build configuration: Debug N

Program path: Debug/NUCLEO-H755-Q_CM4.elf
File system...

Perform build
Download

Use download offset (hex)

Load symbols

Use symbol address (hex)

OK Cancel

The order in the load list is very important. The last entry in the list, marked by a green arrow (refer to Figure 13,
is the image debugged with this debug configuration. Consequently, the debugger fetches the program counter
value (PC) from this image.
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Setting up with ST-LINK GDB server

Startup tab - Cortex®-M4

As shown in Figure 15:

. Make sure that the Port number exceeds the value of the previous debug configuration by at least 3 (61238
in this example)

. Select 3 — Cortex-M4 for [Access port]
. Select None for [Reset behaviour]
. Select Enable shared ST-LINK

Figure 15. ST-LINK GDB server debug configuration (5 of 6)

m Debug Configurations O X
Create, manage, and run configurations 'ﬁ\.
DER@X[EH~ Name:| NUCLEQ-H755-Q_CM4 Debug |

type filter text

] C/C++ Application
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@ Autostart local GDB server Host name or IP address localhost
] C/C++ Postmortem Debugger

] C/C++ Remote Application (O Connect to remote GDB server Port number 61238

[ GDB Hardware Debugging
& Launch Group
# Launch Group (Deprecated)
~ [@ STM32 Cortex-M C/C++ Application Interface
[E NUCLEO-H755-Q_CM4 Debug ®swp  OJTAG [1Use specific ST-LINK S/N ~ | |Sean

[E NUCLEO-H755-Q_CM7 Debu
- 9 Access port: | 3 - Cortex-M4

Reset behaviour

Serial Wire Viewer (SWV)

Main I*# Debugger| & Startup| B Source‘ =] Qommon‘
GDB Connection Settings

Debug probe | ST-LINK (ST-LINK GDB server) |

GDB Server Command Line Options

[1Enable
Clock Settings
Core Clock: | 16.0 MHz

SWO Clock: (2000 M kHz

Port number: | 61235
Wiait for sync packet
Cross Trigger Interface (CTI)
[ Allow other cores to halt this core [ Signal halt events to other cores
Misc
Verify flash download
Enable live expressions

DLD to file: C\Users\ \STM32CubelDE\workspace\NUCLEO-H755-Q\CM4\Debug' |Browse...
9 P 9

[ JExternal Loader: ~ | |Scan
Enable shared ST-LINK

Filter matched 10 of 10 items Revert Apply

@ Debug | ‘ Close
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Setting up with ST-LINK GDB server

Go to the Startup tab and select [Edit...]>[Disable Download]. This is required since the download is already
performed by the Cortex®-M7 configuration (refer to Figure 16).

Figure 16. ST-LINK GDB server debug configuration (6 of 6)

m Debug Configurations O X

Create, manage, and run configurations 'ﬁ\.

CReRX[B>~

type filter text
] C/C++ Application
] C/C++ Attach to Application
] C/C++ Postmortem Debugger
] C/C++ Remote Application
[£] GDB Hardware Debugging
& Launch Group

Name:| NUCLEQ-H755-Q_CM4 Debug |

Main |$ Debugger | Startup| & Source‘ £ Common

Initialization Commands

Load Image and Symbols

File Build Download Load sy... Add...
# Launch Group (Deprecated) Debug\NUCLEQ-H755-Q_CM4.elf [NUC... See Main... ® fal ¢
 [@ STM32 Cortex-M C/C++ Application ebug\ -H755-Q CMAelf [NUC... See Main... © false true

[Z NUCLEO-H755-Q CM4 Debug

[Z NUCLEO-H755-Q_CM7 Debug

Move down

4l

Runtime Options

[ ] Set program counter at (hex):

Set breakpoint at:
Exception on divide by zero

[ ] Exception on unaligned access

Halt on exception

Resume

Run Commands

Revert Apply

Filter matched 10 of 10 items

@ Debug | ‘ Close

The configuration is complete.
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Setting up with ST-LINK GDB server

3141 Launching the configurations
1. Launch the Cortex®-M7 configuration to download both the Cortex®-M4 and Cortex®-M7 images

2. Set the Cortex®-M7 core running so that the HSEM semaphore is released and Cortex®-M4 wakes up from
Stop mode

3. Launch the Cortex®-M4 configuration using the arrow next to the debug icon. It is in the running mode and
the user can halt it.

Figure 17. ST-LINK GDB server debug configuration launch

tvimsvidRE 18 v v
[E 1 NUCLEO-H755-Q_CM4 Debug

[ 2 NUCLEO-H755-Q_CM7 Debug

% 3 New_configuration

Debug As >
Debug Configurations...

Organize Favorites...

Note: After creating the debug configurations for both cores, they are not shown in the scroll-down menu if they have
never been launched before. This is because the arrow provides access to the history of latest launches, with
a grayed “no history” message if there are none. First-time degug launch must be done through the debug
configuration wizard.

When debugging an STM32H7 device with the ST-LINK GDB server, it is possible to create a launch group, which
offers the following advantages:

. The user can launch the debug session on both cores with only one launch configuration as shown in
Figure 18.

Figure 18. ST-LINK GDB server launch group

Create, ge, and run configurati

Launch several other configurations sequentially

[ I—ﬁ o B X ‘ E }:9 e MName: Launch H757
type filter text [ Launches] ] Commen
C/C++ Application
C/C++ Attach to Application
C/C++ Postmortem Debugger
C/C++ Remote Application
GDB Hardware Debugging
a @ Launch Group
|g Launch H757
B Launch Group (Deprecated) |W|
a [ STM32 Cortex-M C/C++ Applicat —
[T H757_CM4 Debug
[ H757_CM7 Debug

Name Mode Action | |
m STM32 Cortex-M C/C++ Application:HI57_CMT7 Debug  Inherit T
m STM32 Cortex-M C/C++ Application:H757_CMW4 Debug  Inherit | Down |

<[ 1 | v

o ——
|

Filter matched 11 of 11 items

® I Debug I [ Close ]

Revert | ‘ Apply |

. The user can stop both cores using the launch group. This avoids having to terminate both debug sessions
individually.
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3.1.2 Cross-trigger Interface

The cross-trigger interface is used to send halt signals from one core to the other. To enable the Cortex®-M4 to
halt the Cortex®-M7, apply the following configuration:

. In the Cortex®-M4 debug configuration: select Signal halt events to other cores
. In the Cortex®-M7 debug configuration: select Allow other cores to halt this core

Figure 19. ST-LINK GDB server debug cross-trigger interface

Cross Trigger Interface (CTI)
D Allow other cores to halt this core D Signal halt events to other cores

Note: Checking both checkboxes in both debug configurations enables both cores to halt each other.
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3.2 Setting up with OpenOCD

Select ST-LINK (OpenOCD) as the [Debug probe]. Select Autostart local GDB server for the configuration that
launches first, which is the Cortex®-M7 in the example in Figure 20. Set all the default options and verify that:
. Connect under reset is selected as [Reset Mode].

[Shared ST-LINK] is selected; this option is mandatory to run the multicore target.

Figure 20. OpenOCD debug configuration (2 of 3)

E Debug Configurations

Create, . and run fi

Cee@X B3
| type filter text

C/C++ Application
C/C++ Attach to Application
C/C++ Postmortem Debugger

MName: | MUCLEQ-HT755-0_CMT7 Debug Open0CD

Main lﬁ» Debuggell > Startup| 73 Source| B Qommon|
GDB Connection Settings
(®) Autostart local GDB server

Host name or IP address | localhost

C/C++ Remote Application () Connect to remote GDB server Port number 3333
GDB Hardware Debugging
L Launch Group Debug probe |ST-LINK (OpenOCD) v

= Launch Group (Deprecated)

GDB Server Command Line Options
~ [[J] STM32 Cortex-M C/C++ Application

OpenOCD Setup
m MNUCLEQ-H733-Q_CM4 Debug Oper
[[] NUCLEQ-H735-Q_CM7 Debug Opet OpenQCD Command:
‘ "§{stm32cubeide_openocd_psth}\openocd.exe” | | Browse...
OpenOCD Options : |

Configuration Script

@ Automated Generation () User Defined

Hide generator options...
Script File: | S{ProjDirPath\NUCLEO-H755-Q_CM7 Debug OpenOCD.cfg | | Browse. || Reload |
Generator Options
Mode Setup
Connection Setup
Reset Mode: | Connect under reset ~
Interface: |Swd ~ ‘
Enable debug in low power modes
Frequency: |8MHz V‘

Stop watchdog counters when halt

Cross Trigger Interface (CTI)

[] Allow other cores to halt this core [] Signal halt events to other cores
ST-LINK Client Setup

Shared ST-LINK

Boards detected by 5T-Link Server: 1

Marne Blink Refresh

SOFF6E067287555137211667

<

Filter matched 10 of 10 items

@

Revert Apply

Debug | ‘ Close
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Create the debug configuration for the other core, which is the Cortex®-M4 in the example in Figure 21:
. Select ST-LINK (OpenOCD) as the [Debug probe]
. Select Autostart local GDB server as default

. Make sure that the Port number exceeds the value of the previous debug configuration by at least 2 (3335 in
this example)

. Open [Generator Options] and select Core reset as [Reset Mode]

Figure 21. OpenOCD debug configuration (3 of 3)

[ Debug Configurations m] X
Create, ge, and run fig i ﬁ‘
= . [ =,
CEREX B~ Name: | NUCLEO-H755-0_CM4 Debug Open0CD |
type filter text 2] Main Deb r| = Startup | B Source | [C] Common
Lo p| %2

C/C++ Application GDB Connection Settings

C/C++ Attach to Application (®) Autostart local GDB server Host name or IP address  localhost

C/C++ Postmortem Debugger

— H— (O) Connect to remote GDB server Port number 3335

C/C++ Remote Application

GDB Hardware Debugging

& Launch Group Debug probe |ST-LINK (OpenOCD) v

= Launch Group (Deprecated) GDB Server Command Line Options

pi
~ [[J] STM32 Cortex-M C/C++ Application Open0CD Setup
E MNUCLEQ-H755-0_CM4 Debug Oper
[ NUCLEO-H755-Q_CMT Debug Oper OpenQCD Command:
"§{stm32cubeide_openocd_pathf\openocd.exe” Browse...
P P P!
OpenQCD Options : | |

Configuration Script

@) Automated Generation () User Defined Hide generator options...

Script File: | S{ProjDirPath\NUCLEO-H755-0_CM4 Debug OpenOCD.cfg | | Browse. || Reload |

Generator Options

Mode Setup
Connection Setup 3 .
Reset Mode: |5Cme reset g
Interface: |Swd ~ ‘
Enable debug in low power modes
Frequency: |8MHz v‘

Stop watchdog counters when halt

Cross Trigger Interface (CTI)
[] Allow other cores to halt this core [] Signal halt events to other cores

ST-LINK Client Setup
Shared 5T-LINK
Boards detected by 5T-Link Server: 1

Marne Blink Refresh

SOFF6E067287555137211667

< > |
Filter matched 10 of 10 items

Revert | ‘ Apply |

@ | Debug | ‘ Close |

The configuration of the Startup tab is the same as with the ST-LINK GDB server probe for both debug
configurations (refer to Startup tab - Cortex-M7 and Startup tab - Cortex-M4 in Section 3.1 Setting up with
ST-LINK GDB server).
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3.21 Launching the configurations

After both debug configurations are set up, save them and click on the arrow next to the debug icon to make sure

launching the autostarting local GDB server first (the Cortex®-M7 in this example). After this first launch, click on
the same arrow again and launch the other configuration.

Figure 22. OpenOCD debug configuration launch

Fry@yvidRETIEHYFH O oY D
[Z 1 NUCLEO-H755-Q_CM4 Debug OpenOCD

X 2 NUCLEO-H755-Q_CM7 Debug OpenOCD

& 3 New_configuration

Debug As >
Debug Configurations...

Organize Favorites...

Note: After creating the debug configurations for both cores, they are not shown in the scroll-down menu if they have
never been launched before. This is because the arrow provides access to the history of latest launches, with

a grayed “no history” message if there are none. First-time degug launch must be done through the debug
configuration wizard.

When debugging an STM32H7 device with OpenOCD, it ispossible to create a launch group, which offers the
following advantages:

. The user can launch the debug session on both cores with only one launch configuration.

Figure 23. Launch OpenOCD debug on both cores

GDB Hardware Debugging
4 7, Launch Group

'8 Lounch 157

= Launch Group (Deprecated) |

Create, ge, and run ig

Launch several other configurations sequentially

SRCEL AR ‘ B3~ Mame: Launch H757

type filter tesxt a8 Launches] ] Commen
C/Cs+ Application Name Mode Action | U |
C/C++ Attach to Application - - .

— m STM32 Cortex-M C/C++ Application:HI57_CM7 Debug  Inherit —

C/C++ Postmortem Debugger | Down |
C/Ce+ Remote Application [7] 5 STM32 Cortex-M C/C++ Application:H757_CM4 Debug  Inherit own

| Remove |
4 m STM32 Cortex-M C/C++ Applical R
[ H757_CM4 Debug
[} H757_CMT7 Debug
< " o
< i |+
Filter matched 11 of 11 ftems [ Revet [ appy |
® I Debug I [ Close ]
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. The user can stop both cores using the launch group. This avoids having to manually terminate both debug
sessions individually. In Figure 24, the launch group in pink handles each of the cores in green.

Figure 24. Stop OpenOCD debug on both cores

= ¥ = O

%5 Debug 2 i Project Explorer & | %
Launch H757 [Launch Group]|
C/ST/STM32CubelDE_1.1.0.19rc3/5TM32 CubelDE/plugins/corm.st,
E ST-LIMK (QpenOCD)
C/5T/5TM32CubelDE_1.1.019rc3/5TM32CubelDE/plugins/com.st,
H757_CMY7 Debug [STM32 Cortex-M C/C++ Application]
a 2 HIST_CMT.elf
a o Thread #1 (Suspended : Breakpoint)
|= main() at main.c:17 0x80002e6 |
= Reset_Handler() at startup_strn32h75Txihix.s:83 0x800034 e
po| C/ST/STM32CubelDE_1.1.0.19rc3/STM32CubelDE/plugins/com.st.
Lﬁ ST-LIMK (QpenOCD)
4 m H757_CM4 Debug [STM32 Cortex-M C/C++ Application]
a 2 HIST_CMA4.elf
a o Thread #1 (Suspended : Breakpoint)
= main() at main.c17 0x81002e5
= Reset_Handler() at startup_stm32h757xihy.=:83 0x810034 e
[55 C:/ST/STM32CubelDE_1.1.019rc3/STM32CubelDE/plugins/com.st)

3.2.2 Cross-trigger interface

The cross-trigger interface is used to send halt signals from one core to the other. To enable the Cortex®-M4 to
halt the Cortex®-M7, apply the following configuration:

. In the Cortex®-M4 debug configuration: select Signal halt events to other cores
. In the Cortex®-M7 debug configuration: select Allow other cores to halt this core

Figure 25. OpenOCD debug cross-trigger interface

Cross Trigger Interface (CTI)
[_] Allow other cores to halt this core [_] Signal halt events to other cores

Note: Checking both checkboxes in both debug configurations enables both cores to halt each other.
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