Banana P1  BPIl:bit

User Manual

Hardware introduction
Software introduction
How to setup and start



Hardware introduction

BPI:bit uses the ESP-WROOM-32 of espressif company as MCU. ESP32 is a single-chip
solution integrating 2.4GHz Wi-Fi and Bluetooth dual mode. The 40 nanometer technology
of TSMC has the best power consumption, RF performance, stability, versatility and reliability.
It can deal with various application scenarios.

Two separate controlled CPU cores, the main frequency can be up to 240MHz, 448KB ROM,
520KB SRAM.

BPI:bit The appearance size is fully matched with Arduino UNO R3
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Hardware Interface :

The BPI:bit is powered by a microUSB or 5.5mm DC power adapter and has an automatic

switching circuit.
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BPI:bit hardware spec

Hardware Specification of Banana pi BPI:bit

CPU Xtensa® 32-bit LX6 single / dual core processor

ROM 448KB

SRAM 520KB

Flash 4MB (On board) , A maximum of 4 Flash/SRAM, each Flash maximum 16MB

Power 5V@1A microUSB power or 5.5mm 12V DC port

GPIO 12-bits SAR ADC 18 channel, 2+8-bit D/A converter, 4xSPI, 2*|2S, 2xI2C,
3*UART, Host SD/eMMC/SDIQ, Slave SDIO/SPI

Wi-Fi 802.11 b/g/n/e/i  802.11 n(2.4GHz 150Mbps) 802.11 e(Quality of
Service)

Bluetooth BT4.2 & BLE

Buzzer Passive buzzer

LEDs RGB LED/POWER LED/Receive LED/Transmit LED

Sizes 68mm=*53mm
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BPI:bit Pin Define

Pin

Name Analog Functionl | Analog Function2 Functionl Function? Power
P3 ADC2_CH4 GPIO13
PO ADC2_CH8 DAC_1 GPIO25
P4 ADC2_CH3 GPIO16
P5 ADC1_CH7 GPIO35
P6 ADC2_CH5 GPIO12
P7 ADC2_CH6 GPIO14
P1 ADC1_CH4 GPIO32
P8 GPIO16
P9 GPIO17
P10 ADC2_CH9 DAC_2 GPIO26
P11 ADC2_CH7 GPIO27
P12 ADC2_CH2 GPI002
P2 ADC1_CH5 GPIO33
P13 GPIO18 SPI_SS
P14 GPIO19 SPI_SCK
P15 GPIO23 SPI_MISO
P16 GPIO05 SPI_MOSI
3V3 POWER:3V3
3V3 POWER:3V3
3V3 POWER:3V3
P19 GPI1022 [2C_SCL
P20 GPIO21 |2C_SDA
GND GROUND
GND GROUND

GND

GROUND




Software introduction

BP:bit can be programmed by many compiling environments, such as PlatformlO for
Atom/VS Code, Arduino IDE, uPyCraft (microPyhton) and ESP-IDF, etc.

PlatformlO for Atom/VSCode Project examples can be viewed
https://github.com/yelvliab/BPI-
uno32_Webduino/blob/master/Test Code/PlatformlO_VSCode/src/main.cpp

PlatformlO for Atom/VS Code detailed installation introduction please click the following
connection :
http://docs.platformio.org/en/latest/ide.html#platformio-ide

Arduino The IDE installation method can look at the official Arduino forum, the links :
http://www.arduino.cn/thread-41132-1-1.html|

You can also look at GitHub's introduction to the Arduino IDE burning document :
https://github.com/yelvlab/BPI-uno32 Webduino/tree/master/Burning/Arduino_IDE

uPyCraft (microPython) The GitHub link of the related data is :
https://github.com/DFRobot/uPyCraft



https://github.com/yelvlab/BPI-uno32_Webduino/blob/master/Test_Code/PlatformIO_VSCode/src/main.cpp
https://github.com/yelvlab/BPI-uno32_Webduino/blob/master/Test_Code/PlatformIO_VSCode/src/main.cpp
http://docs.platformio.org/en/latest/ide.html#platformio-ide
http://www.arduino.cn/thread-41132-1-1.html
https://github.com/yelvlab/BPI-uno32_Webduino/tree/master/Burning/Arduino_IDE
https://github.com/DFRobot/uPyCraft

Programming & Burning :

ESPFlashDownloadTool :

Tools: ESP FLASH DOWNLOAD TOOL

First, download the FLASH_DOWNLOAD_TOOLS_V3.6.2 compression package, unpack the
file in the package and run the tool.

O ESPRESSIF DOWN.. —

ESP8266 DownloadTool

ESP8285 DownloadTool

ESP32 DownloadTool

ESP32D2WD DownloadTool

Run step: when double click open ESPFIashDowaloadTool_v3.6.2, select ESP32 DownloadTool

After the selection, the following software interface will be displayed:

[N ESP32 DOWNLOAD TOOL V3.6.2

SPIDownload, = HSPIDownload RFConfig MultiDownload
Douwnload Path Config

I | 5P32_Module_Test V118_40M_20170919.bin
I | €:\Users\panfeng\Desktop\ESP32_32M _UAR
I | €:\Users\panfeng\Desktop\ESP32_32M _UAR
I~ | DAFAE_puff\2017\ESP_DUMP_TOOL\flash du
I~ | €:\Users\panfeng\Desktophartifacts (4)\builc
I~ | €:\Users\panfeng\Desktop\artifacts (4)\builc
DeviceMasterKey Folder Path

I~ [ cAUsers\panfeng\Desktop\highting _log\id J@ [ 0x1f0000
SpiFlashConfig

P FLASH SIZE
CrystalFreq : CombineBin [~ SpiAutoSet
40M - Default " 8Mbit ™ DoNotChgBin

[ox1000
@ [ox00
[0x0000
[0x000
[0xa000
[0x20000

$PI SPEED SPIMODE | ¢ 16Mbit I™ LOCK SETTINGS
* 40MHz £ alo 0 TR DETECTED INFO
©2%67MHz || © QOUT o GRS
© 20MHz & Do L 1Mt
" 80MHz ¢ DOUT

£ FASTRD

Download Panel 1

IDLE
R

START ‘ sToP ‘ ERASE |COM‘ Com1 -l

BAUD: 1152000 -

For the ESP32 burning test, the test firmware should be selected and the following
modifications should be made:

Download Path Config



We choose firmware files in turn and modify the burning location. The firmware files are
corresponding to the burning location (the location is test firmware folder in the compressed
package).

bootloader.bin 0x1000

partitions.bin 0x8000

boot_app0.bin 0xe000

firmware.bin 0x10000

1. CrystalFreq
Modify it to 26M
2. SPI SPEED
Select 80MHz
3. SPI MODE
Select DIO
4. FLASH SIZE
Select 32Mbit
5. BAUD
Modify it t0115200



Set as below:

|| sPIDownload | HSPIDownload  RFConfig | MultiDownload
—Download Path Config

[™ | C\Users\panfeng\Desktophartifacts (4)\builc ... 0x8000

|_IC:\Users\panfeng\Desk‘lop\arlifads (AMbuile - |@ IOxZOOOO
DeviceMasterKey Folder Path

| I C\Users\panfengiDesktopihighting_loghid _I@ |0x1f0000 |

—SpiFlashConfig )l
|- FLASH SIZE— :
C : CombineBin I™ SpiAutoSet
o I ————{ c ot || T DoNetchgi
SPI SPEED SPI MODE— | ¢ 16Mbit [~ LOCK SETTINGS
(F 2MbD | e g
© A0MHz © aio (RCd BB DETECTED INFO
) R  64Mbit ggih.vg[r;dor:
F/E_OM‘_HZ\ @ 125ME || (R
4016h
@ BOMH:
A ] QUAD:32Mbit
 FASTRD p—
40 Mhz

Download Panel 1

FINISH
SEHE

AP: 30AEA4214C31 STA: 30AEA4214C30
: 30AEA4214C31 ETHERNET: 30AEA4214C30

Then select the hardware to connect the serial port, click START to start automatically
downloading, the above is the successful software state (FINISH completes), reset the
hardware or re power up, so that the software will start running.

Firmware introduction: firmware is divided into four BIN files, and four files must be burned
to ensure normal operation. Firmware content is a blink program with LED_Pin 102. After
burning, the 102 pin level can be measured, and the level interval is 1s.



Arduino IDE :

1. Open File -> Preferences, as shown in the following figure:

Settings etwork

Sketchbook location:

C:\Users\yelvl\Documents'Arduine || Browsze
Editor language: |Eng1ish (English) A (requires restart of Arduina)
Editor font size:

Interface scale: ] Automatic (requires restart of Arduine)

| Show verbose output during: Dcompilation Dupload

Compiler warnings:

I:‘Display line numbers

[JEnahle Code Folding

1r’ex:i.'fy code after upload

I:‘Use external editor

[ ggressively cache compiled core

Chec]{ for updates on startup

[] Update sketch files to new extension on save (.pde —> .ina)

[ Save when verifving or uploading

Additional Boards Manager URLs: | tps://git. oschina. netfdfrohotﬂ’i.reﬁeetle—ESPSZ;"raw'masterfpackage_espSZ_index._isor|

More preferences can be edited directly in the file
C:\Users\yelvl\AppData\Local \ArduinelS\preferences. txt

{edit only when Arduine iz not running)

2. Click the button in the red circle above and add the following URL

in the newly popped window:

https://git.oschina.net/dfrobot/FireBeetle-
ESP32 /raw/master/package_esp32_index.json
As shown below:

2@ Additional Boards Manager URLs

Enter additional URLs, one for each row
j t.oschina. net/dfrobot/FireBeetle-ESP32/raw/naster/package_espl2_index. json ™
n
5 W
11« »
®] Click for a list of unofficial boards suppert URLs
! | 0K | | Cancel
 EEEEEEEEE——————n



3. Open Tools->Board->Board Manager. Pull down to see FireBeetle-ESP32 and click Install.

2@ Boards Manager

Twpe (ALl w | |Fil

EMORO 2560 by Inowvatic-ICT

Eoards included in this package:

EMoRo 2560. Board based on ATmega 2560 MCU.
Online help

More info

Industruine SAMD Boards (32-bits ARM Cortex-M0+) by Industruine
Boards included in this package:

Industruine D21G.

Cnline help

More info

FireBeetle-ESP32 Mainboard by DFRobot DFRDuino version 0.0.7 INSTALLED
Boards included in this package:

FireBettle-ESP22.

More info

Select version | Install Remove

Close

4. Open a project in the upper left corner of the file, or open an example.

28 WiFiScan | Arduino 1.8.3 = O o

Eile Edit Sketch Tools Help

WiFiScan

#include “TiFi.h"

vold setup

71

I

Serial.begin(115200) ;

LR

// Set WiFi to station mode and discornect from an AP if it was previously cornec

i WiFi.mode (TIFI_STA);

[ WiFi. disconnect();
delay(100);

X

Crveial raeimt Tl " Totran Ammn ™




5. Select a correct port in Tools -> Ports, then click .will be compiled code, clic
will be burn programs

@@ GetChiplD | Arduino 1.8.3

etch Tools Help

GetChiplD

7 |int64 + enipig; 2
void setup() { Lo
l{  Serial.begin(115200);
| F
void loop() {

5 chipid=ESP. getEfuselMlac();//The chip ID is essentially its MAC address(length: 6 byt
Serial.printf ("ESP32 Chip ID = %04X", (uint16_t) (chipid>»32));//print High 2 bytes
Serial.printf ("%08X\n”, (uint32_t)chipid);//print Low 4bytes. }i

delav(3000); }]

b= =~

@ GetChiplD | Arduino 1.8.3

| E Sketch Tools Help

GetChiplD

llimﬁ-Lr. chipid;

void setup() {
Serial. begin(115200);

q void loop() {

chipid=ESP. getEfuselMac();//The chip ID is essentially its MAC address(length: 6 byt
Serial.printf("ESP32 Chip ID = %04X", (uintl6_t) (chipid>»32));//print High 2 bytes
Serial.printf ("%08¥\n", (uint32_t)chipid);//print Low 4bytes.

Il

delay(3000);




PlatformlO for Atom/VS Code

1. First open the PlatformlO Home page, then click Open Project to open the project. (You
can choose the test code.) If you write your own code to burn, then the platformio.ini file
should write the following code
[env:BPI-BIT]
platform = espressif32
board = nodemcu-32s

framework = arduino

G main.cpr PIO Home X%

¥ rllowUs B @ O Have an account? L¢

Welcome to PlatformlO Show at startup

Recent Projects




2. The code path under PlatformlO project is generally src/main.cpp. Open the code and
use Ctrl+" to open the terminal debugger. Enter platformio run --target upload.

D‘I EXPLORER

4 OPEN EDITORS

p G maincpp st M

@ README.md

\x@) 4 PLATFORMIO_VSCODE

b .pioenvs
b .vscode
b lib
9]
L..I 4 src
€ main.cpp M

.clang_complete
{} .gce-flagsjson
€ _gitignore
! travisyml

platformio.ini
@ README.md

104

T {} localejson C:\User...

File Edit Selection View Go Debug Tasks Help

G maincpp X (@ READMEmd {} localejson
Uint3z_t duty = (8191 / 255) * value;

rite duty to LEDC

te(channel, duty);

void setup()
{
serial.begin(1152e@); //Seri
while (!serial)
; // wait for serial attach

serdial.println();
Serial.println("Initializing...");
Serial.flush();

Serial.println();
Serial.println("BPI-uno32 Function Test Demo™);
serial.println("Running...");

R P R JEL W 1

PROBLEMS ouTPUT DEBUG CONSOLE TERMINAL 1: platformic ¥ + T @ ~ OO0 x

E:\Code Repository\BPI-uno32 Webduino\Test Code\PlatformIO VSCodel

[@3/22/18 16:27:11] Processing BPI-u

Verbose mode can be enabled via "-v, --verbose® option
PLATFORM: Espressif 32 > NodeMCU-325

SYSTEM: ESP32 24@MHz 288KB RAM (1.25MB Flash)

Library Dependency Finder -> http://bit.ly/configure-pio-1df
LDF MODES: FINDER(chain) COMPATIBILITY(light)

Collected 28 compatible libraries

Scanning dependencies...

Dependency Graph

|-- <WiFi> vi.@

Compiling .piocenvs\BPI-uno32\src\main.cpp.o

<command-1in 1

Pmaster S @O0AD & Serial Monitor Q Library & #  Checking PlatiormlO Core In112,Col 10 Spaces: 4

: warning: ISO C++11 requires whitespace after the macro name

UTF-8 CRLF

22 (platform: espressif32; board: nodemcu-32s; framework: arduino)

Crs

win3iz @ A




Make sure the board is connected. The program will be compiled first and then burned

into the BPI-uno32 board. There are some points to note. If the above code does not

specify the port, please try to avoid other serial devices connected on the computer. For

serial port numbers, run platformio --help.

cpp - Platfor

File Edit Selection View Go Debug Tasks Help

D‘I EXPLORER

4 OPEN EDITORS
G maincpp st M
@ README.md
@ 4 PLATFORMIO_VSCODE

b .pioenvs

b .vscode

b lib

4 src
€ main.cpp M
.clang_complete

.gece-flagsjson
€ _gitignore

travisyml
platformio.ini
@ README.md

¥ omaster S

{} localejson C:\User...

@0 A0 & Serial Monitor

G maincpp X (@ READMEmd {} localejson
Uint3z_t duty = (8191 / 255) * value;

orit uty LEDC

channel, duty);

duty to

void setup()

{
serial.begin(1152e@);
while (!serial)

H ait

serdial.println();
Serial.println("Initializing...");
Serial.flush();

Serial.println();

Serial.

Comiind

rintln("Running...");

TR P

PROBLEMS ouTPUT DEBUG CONSOLE TERMINAL

E:\Code Repositcr‘y\BPI-uno}Zjlebduino\TestﬁCcde\PlatFormIOﬁVSCcde*Jlatf-or'mio run --target upload |
2 (platform: espressif32; board: nodemcu-32s; framework: arduino)

[@3/22/18 16:27:49] Processing

Verbose mode can be enabled via "-v, --verbose® option
PLATFORM: Espressif 32 > NodeMCU-325

SYSTEM: ESP32 24@MHz 288KB RAM (1.25MB Flash)

Library Dependency Finder -> http://bit.ly/configure-pio-1df
LDF MODES: FINDER(chain) COMPATIBILITY(light)

Collected 28 compatible libraries

Scanning dependencies...

Dependency Graph

|-- <WiFi> vi.@

Linking .pioenvs\BPI-uno32\firmware.elf

Checking program size

text data bss dec

Q Library & -

hex filename

Checking PlatformlO Core

p
Serial.println("BPI-uno32 Function Test Demo™);
p

T:platformic Y| 4+ M @ ~ O x

Ln 112, Col 10 Spaces: 4

UTF-8 CRLF

Crs

win3iz @ A




uPyCraft (microPyhton) :

1. first open the uPyCraft software, click the Tools->Serial port to select the port in the upper
toolbar. After selecting port, the software will automatically decide whether to burn the

firmware, if necessary, the interface will be popped up.
F3 uPyCraft v0.29

File Edit Tools Help

J ¢ Serial » W
a # board o lij ﬁ
> 0 device _

" sd
A,
» O uPy_l1l
<) workSp & Stop
v BurnFirmware

Download
DownloadAndRun F5

i@ InitConfig

% Preferences

2. when the software interface is opened, we choose ESP32 in board. If erase_flash chooses
yes, it will wipe out the original flash first, and generally choose to erase it, so that the
original flash will have an impact on it now.

F3 Burn Firmware

board esp3’ -

erase_flash yes -

Firmware Choose

® uPyCraft
() Users

ok cancel




3. after the selection, click Yes to start the burning, there will be the following dialog, only
to wait for it.

E Burn Firmware

Download

EraseFlash

Burn

when the Burn column is full, the dialog box automatically closes and displays the software
master interface.

F] Burn Firmware




| Q} b
4. Inthe main interface we can click to connected. It is located in the lower row of the

toolbar. The following interface will appear after the connection

F3 uPyCraft V0.29
File Edit Tools Help

ROBPESYHSYNEDLT I

£

{ > [ device I
7 sd
> A uPy_lib
71 workSpace

Lisl

= 0 w0 @ =

This means we can appear > > > for interactive programming like to Python in the following
dialogue.



Basic function test :

You can visit GitHub to download the test code, compile, burn, and observe the test results
through the serial port.

Project link (PlatformlO) :
https://github.com/yelvlab/BPI-
BIT/tree/master/Test Code/BasicFunction/PlatformlO VSCode

MPU9250 test:

You can visit GitHub to download the test code, compile, burn, and observe the test results
through the serial port.
https://github.com/yelvlab/BPI-BIT/tree/master/Test_Code/MPU9250/PlatformIO_VSCode



https://github.com/yelvlab/BPI-BIT/tree/master/Test_Code/BasicFunction/PlatformIO_VSCode
https://github.com/yelvlab/BPI-BIT/tree/master/Test_Code/BasicFunction/PlatformIO_VSCode
https://github.com/yelvlab/BPI-BIT/tree/master/Test_Code/MPU9250/PlatformIO_VSCode

How to setup and start

Need to be prepared : BPI-UNO32x1, Jumper Cap*4. microUSBx1
quickstart :
1. connect the four jumper caps to the top of the board, respectively, to connect the RGB

LED to the buzzer. Then use the microUSB line to connect the development board to the
computer.

Port :
9 =it
v | &0 (CoM # LPT)
ﬁ USB-SERIAL CH340 [(COMYT)
W B
connected :




open VS Code (you can also choose other compilers) and open BPI-UNO32 on the
PlatformlO Home page Code project, for example, to open a test code engineering
folderPlatformlO_VSCode,
Project:

Open PlatformlO Project

Favorites

Places

Devices

open the VS Code terminal console, input <platformio run>, compile the program, input
<platformio run --target upload>, compile and burn the program. (if it hasn't been
compiled before, it may be slow to compile the first time and need to be connected
because he needs to get the corresponding platform information).
platformio run :
PROBLEMS QUTPUT DEBUG CONSOLE TERMINAL 1: cmd v + M O ~ O x
E:\Code Repository\BPI-uno32 Webduino\Test Code\PlatformIO VsCode

[63/22/18 16:27:11] Processing (platform: espressif3z;

Verbose mode can be enabled via ~-v, --verbose’ option
PLATFORM: Espressif 32 » NodeMCU-32S
SYSTEM: ESP32 248MHz 288KB RAM (1.25MB Flash)
Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF MODES: FINDER(chain) COMPATIBILITY(light)
Collected 28 compatible libraries
Scanning dependencies...
Dependency Graph
-- <WiFi> v1.@
Compiling .pioenvs\BPI-uno32\src\main.cpp.o

Linking .pioenvs\BPI-uno32\firmvare.elf
fnnitor O Likhran e - Checkina PlatformIC) Care - 2 Cal 10 Snacec 4 LITF-A “RIF g Win2? @& A



platformio run --target upload :

PROBLEMS OUTPUT DEBUG COMSOLE TERMINAL 1: platformio ¥ + M @& ~ O x

E:\Code Repository\BPI—unoBZ_Hebduino\Test_pode\PlatFormIO_MSCodelplatformio run --target uploadl
[83/22/18 16:27:49] Processing (platform: espressif32; board: nodemcu-32s; tramework: arduino)

Verbose mode can be enabled via *-v, --verbose” option
PLATFORM: Espressif 32 > NodeMCU-32S

SYSTEM: ESP32 24@MHz 288KB RAM (1.25MB Flash)

Library Dependency Finder -» http://bit.ly/configure-pio-1df
LDF MODES: FINDER{chain) COMPATIBILITY(light)
Collected 28 compatible libraries

Scanning dependencies...

Dependency Graph

|-- <WiFi> vi.8

Linking .pioenvs\BPI-uno32\firmware.elf

Checking program size

text data bss dec hex filename

fonitor O Library &P - Checking PlatformIC Core Ln 112, Col 10 Spaces:4 UTF-8 CRLF C++ Win32 @ A

then open the serial port assistant tool, select BPI-UNO32 on the computer
corresponding to the serial serial number, the serial port settings are selected as:

Baud rate: 115200 Data bit: 8 Parity check: no Stop bit: 1
Serial Config :

Corfigure the serial line

Speed (baud) [ 115200 |
Data bits E |
Stop bits | 1 |
Parity None v

Test content

RGB LED fading.

AD acquisition and testing of 6 ADC_channell.

WiFi scan testing.

Control test of buzzer gradient.



