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User's Guide
SWRU376A–June 2014–Revised June 2014

CC3200 SimpleLink™ Wi-Fi® and IoT Solution With MCU
LaunchPad™ Getting Started Guide

This guide is intended to assist users in the initial setup and demonstration of the Getting Started with
WLAN Station application. The guide explains how to install an Integrated Development Environment
(IDE), and then compile, download and debug Getting Started with WLAN Station.

1 Introduction

1.1 Prerequisites
The user should have the following items:
• One CC3200-LAUNCHXL
• An 802.11b/g/n (2.4 GHz) Wireless Access Point (AP).
• A computer running the Microsoft® Windows® 7 or XP operating systems.

SimpleLink, LaunchPad are trademarks of Texas Instruments.
Wi-Fi is a registered trademark of WiFi Alliance.
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2 Getting Started

2.1 Download and Install Software
Download and install the following software:
• CC3200 SDK package.

– This guide assumes the use of the default installation folder C:\TI\CC3200SDK\.

2.2 Configure Board
The jumpers on the CC3200-LAUNCHXL should be connected as shown in Figure 1. It may be necessary
to move a jumper from P58-VCC to SOP2.

Figure 1. Jumpers on the CC3200-LAUNCHXL

2.3 Install USB Driver
1. Connect the CC3200-LAUNCHXL to the PC using the provided micro-USB cable.
2. Open the Windows Device Manager by selecting Start Menu>Control Panel>Device Manager. The

CC3200-LAUNCHXL will appear as two instances of “USB <-> JTAG/SWD” under the category Other
Devices as shown in Figure 2. For both of these instances, the driver software will need to be updated.
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Figure 2. Windows Device Manager

3. Right click on the first instance of “USB <-> JTAG/SWD” and select “Update Driver Software…”
4. Select “Browse my computer for driver software.”

Figure 3. Update Driver Software

5. Fill the search path as C:\TI\CC3200SDK\cc3200-sdk\tools\ftdi, and press next. There is no need to
restart the PC.
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Figure 4. Browse for Driver Software

6. Repeat the above three steps for the other instance of "USB <-> JTAG/SWD."
7. Repeat the same steps for the instance of “USB Serial Port” that should have appeared as shown in

Figure 5.

Figure 5. USB Serial Port

8. The CC3200-LAUNCHXL will now be visible in the Device Manager as shown in Figure 6. Note the
COM port number that appears.
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Figure 6. Device Manager
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3 Compile, Download, and Debug
The CC3200 SDK supports CCS 6.0, IAR 7.10.3 and GCC IDE/compiler. The example shown here is
Getting Started with WLAN Station, and performs the following functions:
1. Switches to Station mode if the device is in AP mode.
2. Connects to the user's Access Point (default SSID is ‘cc3200demo’). If the connection to the AP is

successful, the red LED (D7) will switch on.
3. Pings the user's Access Point. If the ping test is successful, the green LED (D5) will switch on.
4. Pings to www.ti.com to check Internet connectivity. If the ping test is successful, the orange LED (D6)

switches on.

This example uses a Real Time Operating System (RTOS).

3.1 Option 1: Code Composer Studio (CCS)

3.1.1 Download and Install
Download and run the Code Composer Studio 6.0 (CCS) installation wizard (ccs_setup_win32.exe) from
http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v6 The program must be
Version 6.0.0.00190 or later. Select the Wireless Connectivity MCUs option for processor support. The
remaining options for the installer should be left as the default. Installation time is typically 20 minutes, but
can vary based on internet connection speed.

Figure 7. Code Composer Studio v6 Setup

3.1.2 Install TI-RTOS for SimpleLink and CC3200 Support Package
Install TI-RTOS for SimpleLink from the CCS App Center:
1. Start CCS, and choose a Workspace folder (the folder where the projects reside).
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2. Open the App Center from the Help->Getting Started screen.
3. Search 'CC3200' in the App Center to find 'TI-RTOS for SimpleLink' and 'CC3200 Add-On'
4. Select TI-RTOS
5. Select the CC3200 Add-On
6. Press 'Install Software'

Figure 8. CCS App Center

3.1.3 Import and Configure Project
1. Choose Projects>Import CCS Projects from the menu.
2. Select the Browse button in the Import CCS Eclipse Projects dialog, and Select the directory

C:\TI\CC3200SDK\cc3200-sdk.
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Figure 9. Select CCS Projects to Import

3. Select the wlan_station, driverlib, simplelink, oslib and ti_rtos_config projects. Click Finish. For this
tutorial, do not check the 'Copy projects into workspace' option. This would cause the project's links to
it's dependencies to be broken since relative paths are used.
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Figure 10. Select CCS Projects to Import

4. Setup the ti_rtos_config project configuration as shown in Figure 11. Select the latest versions of
XDCtools and TI-RTOS for SimpleLink. Also verify the platform is selected as
ti.platforms.simplelink:CC3200.
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Figure 11. Properties for ti_rtos_config

5. Select the simplelink project and build it as shown in Figure 12.
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Figure 12. Select simplelink Project

6. Select the ti_rtos_config project and build it.
7. Select the driverlib project and build it.
8. Select the oslib project and build it.
9. Open the main.c file of the wlan_station project for editing at C:\TI\CC3200SDK\cc3200-

sdk\example\getting_started_with_wlan_station\main.c.
10. Edit main.c to use the SSID, security type and security key of the Access Point being used. Edit the

macros SSID_NAME, SECURITY_TYPE and SECURITY_KEY to contain the Access Point’s
information as shown in Figure 13. The security types supported for this demo are WPA/WPA2 and
Open. For Open security, define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2
security, define it as SL_SEC_TYPE_WPA. Alternatively, the SSID and security of the Access Point
being used can be changed to match the default (SSID: cc3200demo, Security: Open).

Figure 13. Editing main.c

11. Save main.c.
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12. Select the wlan_station project and build it.
13. The target configuration needs to be set before debugging from CCS. Navigate to View>Target

Configurations.

Figure 14. Target Configurations

14. Right Click on “User Defined,” select “Import Target Configuration” and select the file CC3200.ccxml
from C:\TI\CC3200SDK\cc3200-sdk\tools\ccs_patch\. Select the Copy files option when prompted.

Figure 15. Import Target Configuration
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15. Set this new configuration as the default by right clicking on the file name as shown in Figure 16.

Figure 16. Set as Default

16. Launch application. Select the wlan_station project in Project Explorer, then click the debug icon as
shown in Figure 17 to download code to the device and begin debugging. Press F8 to begin execution.

Figure 17. Debug wlan_station

Caution: Only one FTDI board should be connected to the PC while CCS downloads code to device.

3.2 Option 2: IAR Workbench

3.2.1 Download IAR
The CC3200 SDK has been built and tested with IAR 7.10.3, and older versions of IAR projects might not
work properly on IAR 7.10.x. Most examples will only run with the fully licensed IAR Workbench.
1. Download IAR for ARM processors from the IAR System website, and install it using the installation

wizard.
2. Copy the file c:\TI\CC3200SDK\cc3200-sdk\tools\iar_patch\armLMIFTDI.dll into the folder C:\Program

Files (x86)\IAR Systems\Embedded Workbench 7.0\arm\bin (will need to replace existing file).

16 CC3200 SimpleLink™ Wi-Fi® and IoT Solution With MCU LaunchPad™ SWRU376A–June 2014–Revised June 2014
Getting Started Guide Submit Documentation Feedback

Copyright © 2014, Texas Instruments Incorporated

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376A


www.ti.com Compile, Download, and Debug

3.2.2 Rebuild the SimpleLink Driver
1. Start IAR and select File>Open>Workspace from the menu.

Figure 18. IAR Embedded Workbench IDE

2. Open the simplelink project by navigating to C:\TI\CC3200SDK\cc3200-sdk\simplelink\ewarm and
opening simplelink.eww.
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Figure 19. Open simplelink.eww

3. Rebuild the simplelink project by selecting Project>Rebuild All from the menu as shown in Figure 20.
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Figure 20. Rebuild the simplelink Project.

3.2.3 Rebuild, Download and Debug the WLAN Station Example
1. Open the wlan_station project by selecting File>Open>Workspace from the menu, navigating to

C:\TI\CC3200SDK\cc3200-sdk\example\ getting_started_with_wlan_station\ewarm, and opening
wlan_station.eww.

2. Open the main.c file of the wlan_station project for editing at C:\TI\CC3200SDK\cc3200-
sdk\example\getting_started_with_wlan_station\main.c.

3. Edit main.c to use the SSID, security type and security key of the Access Point being used. Edit the
macros SSID_NAME, SECURITY_TYPE and SECURITY_KEY to contain the Access Point’s
information as shown in Figure 21. The security types supported for this demo are WPA/WPA2 and
Open. For Open security, define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2
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security, define it as SL_SEC_TYPE_WPA.

Figure 21. Editing main.c

4. Save main.c.
5. Rebuild the wlan_station project by selecting Project>Rebuild All from the menu.
6. The debugger must be configured to download code to the device. Select Project>Options from the

menu, and select the Debugger category. In the Setup tab, choose TI Stellaris as the driver, as shown
in Figure 22, and press OK.

Figure 22. Select TI Stellaris Driver

7. Click the debug icon as shown in Figure 23 to download code to the device and start debugging.
Select Debug>Go from the menu or press F5 to begin execution.
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Figure 23. Debug Icon

3.3 Option 3: GCC
This section demonstrates the GCC setup for the Windows 7 environment. GCC installation requires other
dependencies to be installed to work with ARM-based devices.

3.3.1 Install Cygwin (Windows)
1. Download setup-x86.exe from http://cygwin.com/install.html and run it. Select the Install from Internet

option.
2. Specify a proxy if necessary, depending on the network.
3. Choose a download site (for example, http://mirrors.kernel.org).
4. Include the latest versions of the following packages in the Cygwin installation (in addition to those

included in the base installation):
• Archive/unzip
• Archive/zip
• Devel/autoconf
• Devel/automake
• Devel/libtool
• Devel/make
• Devel/subversion (Note: if using TortoiseSVN/Windows7, skip this file)
• Devel/gcc-core
• Devel/gcc-g++
• Devel/mingw-gcc-core
• Devel/mingw-gcc-g++
• Devel/mingw-runtime
See Figure 24 for an example of selecting a package (as example: Devel/autoconf).
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Figure 24. Cygwin Setup

5. The system will find dependencies. Press Next.
6. After a successful Cygwin installation, add its path (c:\cygwin\bin\) to the Windows environment

variable PATH by going into Control Panel>System>Advanced System Settings>Environment
Variables. Under System Variables, select PATH and press Edit. Append “;C:\cygwin\bin\” to the end of
the line and press Ok.

3.3.2 Get GNU Tools for ARM Embedded Processors
Download and run the latest version of gcc-arm-none-eabi-<version>-win32.exe from
https://launchpad.net/gcc-arm-embedded. The link to the file should be on the right side of the page and
will appear as a green button with the text: ”gcc-arm-non...4-win32.exe.” Install under the Cygwin root
directory (default: c:\cygwin).

3.3.3 Build OpenOCD for FTDI Interface
1. Download the Open On-Chip Debugger (OpenOCD) source from

http://sourceforge.net/projects/openocd/files/openocd/0.7.0/ Look for the zip file openocd-0.7.0.zip.
2. Extract the OpenOCD source into the Cygwin directory (c:\cygwin). This will create a directory called

openocd-<version> (for example, c:\cygwin\openocd-0.7.0) under the Cygwin directory containing all
the OpenOCD source contents.

3. Download the FTDI driver library (x86 [32-bit] zip version) at
http://www.ftdichip.com/Drivers/CDM/CDM%20v2.10.00%20WHQL%20Certified.zip.

4. Extract the FTDI source into the path c:\cygwin\openocd-<version> ftd2xx (for example,
c:\cygwin\openocd-0.7.0\ ftd2xx).

5. Run the Cygwin terminal and change the directory to openocd-<version> (for example, by using a
command such as: cd c:cygwin/openocd-0.7.0).
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6. Run the following command:

./configure --enable-maintainer-mode --disable-werror --disable-shared --enable-ft2232_ftd2xx -
-with-ftd2xx-win32-zipdir=ftd2xx
The command should look similar to Figure 25.

Figure 25. Cygwin Terminal

The last lines of the result should appear as in Figure 26.

Figure 26. Cygwin Terminal

7. Run the command ‘autoreconf --force --install.'
8. Run the command ‘make.’ This may take several minutes. The last lines of the result should appear as

in Figure 27.

Figure 27. Running the Make Command

9. Run the command ‘make install.’ The last lines of the result should appear as in Figure 28.
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Figure 28. Running the Make Install Command

10. After the command has run successfully, check that the file openocd.exe is generated at path
C:\cygwin\usr\local\bin. Add this path to the Windows PATH environment variable.

3.3.4 Compile the GCC SDK project
1. Open the main.c file of the wlan_station project for editing at C:\TI\CC3200SDK\cc3200-

sdk\example\getting_started_with_wlan_station\main.c.
2. Edit main.c to use the SSID, security type and security key of the Access Point being used. Edit the

macros SSID_NAME, SECURITY_TYPE and SECURITY_KEY to contain the Access Point’s
information as shown in Figure 29. The security types supported for this demo are WPA/WPA2 and
Open. For Open security, define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2
security, define it as SL_SEC_TYPE_WPA.

Figure 29. Editing main.c

3. Save main.c.

In the Cygwin terminal, change the directory to C:\TI\CC3200SDK\cc3200-sdk\
example\getting_started_with_wlan_station\gcc\ and run following command:
make –f Makefile

This command should appear as in Figure 30. Note that Cygwin uses forward slashes to separate
directories.
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Figure 30. Makefile Command

This generates the wlan_station.axf file under the gcc\exe folder.

3.3.5 Target Connection and Debug (GDB)
1. The OpenOCD configuration file for FTDI is present under the C:\CC3200SDK\cc3200-sdk\

tools\gcc_scripts\ folder. To test the connection to the CC3200 FTDI Launchpad, navigate to the
<cc3200-sdk>\tools\gcc_scripts folder in the Cygwin terminal, run the following command and check
the output to see if the connection happened properly.
openocd -f cc3200.cfg

See Figure 31 for the output screen while the CC3200 device is connected through GDB.

Figure 31. Output Screen

2. Press <ctrl>+c to return to prompt.
3. Copy the wlan_station.axf file found in C:\TI\CC3200SDK\cc3200-sdk\

\example\getting_started_with_wlan_station\gcc\exe\ to the directory C:\TI\CC3200SDK\c3200-
sdk\tools\gcc_scripts\.

4. To start debugging using GDB on CC3200, go to C:\TI\CC3200SDK\cc3200-sdk\tools\gcc_scripts\ and
run the following command at the Cygwin prompt:
arm-none-eabi-gdb -x gdbinit wlan_station.axf

See Figure 32 for the result of debugging the wlan_station application from GCC.
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Figure 32. Debugging wlan_station

This results in a GDB prompt. To continue, type ‘continue’ and press enter. For other commands, consult
the GDB Quick Guide.
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4 Summary
After the development environment has been set up, see the following resources for further assistance in
development:
• CC3200 Programmer's Guide – This guide contains information on how to use the SimpleLink API for

writing WLAN-enabled applications.
• PinMux Tool – This utility helps determine how to best assign peripherals to the appropriate CC3200

package pins.
• Uniflash – The Uniflash tool manually stores files on the external serial flash. This includes the

application binary and SimpleLink firmware patch files. Also, any configuration files, security
certificates, web pages, and so forth can be stored using this tool.

• CC3200 Wiki – All information and tools for the CC3200, including the above, can be found on the
CC3200 Wiki page.
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5 Acronyms Used
STA – Wi-Fi Station

AP – Wi-Fi Access Point

WLAN – Wireless LAN

CCS – Code Composer Studio

GCC – GNU Compiler Collection
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale
supplied at the time of order acknowledgment.
TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.
TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.
Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
TI is not responsible or liable for any such statements.
Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use
of any TI components in safety-critical applications.
In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.
No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.
Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.
TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

Products Applications
Audio www.ti.com/audio Automotive and Transportation www.ti.com/automotive
Amplifiers amplifier.ti.com Communications and Telecom www.ti.com/communications
Data Converters dataconverter.ti.com Computers and Peripherals www.ti.com/computers
DLP® Products www.dlp.com Consumer Electronics www.ti.com/consumer-apps
DSP dsp.ti.com Energy and Lighting www.ti.com/energy
Clocks and Timers www.ti.com/clocks Industrial www.ti.com/industrial
Interface interface.ti.com Medical www.ti.com/medical
Logic logic.ti.com Security www.ti.com/security
Power Mgmt power.ti.com Space, Avionics and Defense www.ti.com/space-avionics-defense
Microcontrollers microcontroller.ti.com Video and Imaging www.ti.com/video
RFID www.ti-rfid.com
OMAP Applications Processors www.ti.com/omap TI E2E Community e2e.ti.com
Wireless Connectivity www.ti.com/wirelessconnectivity
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