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1 Purpose

A simple Webserver and HVAC controller has been constructed to demonstrate the use of command
and control as well as remote monitoring via a robust, secure, low energy 802.11n WiFi connection.

The lab is intended for use on the TWR-MCF5225X-KIT: Tower System Coldfire® V2 MCF5225X
Connectivity Module or the TWR-K60N512-KIT: Development Kit

2 Configuring the TWR-WIFI-AR4100 Hardware

Tower Configuration

Jumpers

Serial Flash

External Antenna
Connector

Onboard Antenna

Atheros AR4100
802.11n

Primary
Connector

Expansion
GPIO Header

Secondary
Connector

TWR-WIFI-AR4100 Jumper Options

The following is a list of all jumper options. The default installed jumper settings are shown in

bold.

Setting

Description

J1

12

J11

J22 J16 J15 J14 J13 )12

J23

Supply 3.3V to AR4100 via Tower Elevator (J1 can be used as a

AR4100 el Source B point for AR4100 specific power usage)
Selection 2-3 Not Used (On-board power regulation is not implemented by default)
AR4100 1.8V Power 12 Supply 1.8V to the AR4100 (J2 can be used as a measurement point
Regulation specific to the AR4100 1.8V)
AR4100 Power Down 1-2 Power down the AR4100
AR4100 Reset/Power 1-2 Tower System RSTOUT_b will control reset / power down of AR4100
Down Selection 2-3 | Tower System GPIO3 will control reset / power down of AR4100
Interrupt Select (IRQ_G) 1-2 Tower System IRQ_G will connect to AR4100 SPI_INT
Interrupt Select (IRQ_E) 1-2 Tower System IRQ_E will connect to AR4100 SPI_INT
Interrupt Select (IRQ_C) 1-2 Tower System IRQ_C will connect to AR4100 SPI_INT
Interrupt Select (IRQ_A) 1-2 Tower System IRQ_A will connect to AR4100 SPI_INT
TWR-WIFI-AR4100 12 Supply 3.3V to TWR-WIFI-AR4100 via Tower Elevator (J23 can be used as

Power Connection

a measurement point for the entire TWR-WIFI-AR4100 module)

TWRWIFIAR4100LAB
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3 Installing the Development Environment

When running this demo on the ColdFire platform obtain the Code Warrior Development Environment
Code Warrior Landing Page
http://www.freescale.com/webapp/sps/site/prod summary.jsp?code=CW-COLDFIRE
Now Register, Download and Install the evaluation copy of Code Warrior 7.2

When running this demo on the Kinetis K60 Platform obtain the IAR Development Environment
IAR Landing Page http://www.freescale.com/webapp/sps/site/prod summary.jsp?code=TWR-
K60N512-1AR
Now Register, Download and Install the evaluation copy

4 Installing the TWR-WIFI-AR4100 MQX Patch

Obtain the Qualcomm Atheros (QCA) Patch and follow the Installation instructions below for the given
platform.

Visit http://freescale.com/towerwifi and select TWR-WIFI-AR4100 from the list of available Tower WiFi
modules. The TWR-WIFI-AR4100 MQX patch is available under the “Downloads”.

Steps for installing the Qualcomm Atheros MQX Patch

a. Toinstall Qualcomm Atheros patch, please install MQX 3.6.2 first.
The QCA setup will patch QCA specific changes to the mgx tree.
b. Click setup.exe

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 4 of 21
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atheros_reflash_intflash_d.elf 3/31/2011 6:41 PM CodeWarrior ELF ... 1613 KB
&) 10T _Dev_Windows.20_INSTALL4.0.012 - ... 4/4/2011 5:54 PM Shortcut 2KB
P Setup.exe 4,/472011 5:46 PM Application 4,290 KB
Jade AR4100 Driver Install (=23
License Agreement ‘ 1
Pleaze read the following license agreement carefully. I’{-M
ATHEROS COMMUNICATIOMS, INC. -

SOFTWARE LICENSE AGREEMENT

IMPORTANT - READ CAREFULLY: This Software License
Agreement (“Agreement™) is a legal agreement between
you (either an individual or a single entity) (“You"
or “Licensee™) and Atheros Communications, Inc.
(“Atheros™) for the Atheros software, hardware
design files, and related documentation that

qqqqqqqqqqq el - Amememmmnmemd FOOC o Dy e A Tl m

@) | accept the terms af the licenze agreement

() | do not accept the terms of the license agresment

-

< Back ][ et > l [ Cancel l
c. Browse to the location of installed MQX package
(typically C:\Program Files\Freescale\Freescale MQX 3.6).
| Jade AR4100 Driver Install =
Choosze Destination Location ‘
Select the folder where the installation program will inztall the files. I’{rh

C: g

Setup will install the Jade AR4100 Driver Install Applications into the follmwing directon:

Destination Folder

Browse...

< Back ][ Mext = ][ Cancel ]

TWRWIFIAR4100LAB
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d. Once the package is installed, two new demo applications will be installed in the demo folder
(hvac_wifi & web_hvac_ wifi).

5 Building / Flashing the Demo Application

5.1 TWR-MCF5225X with CodeWarrior 7.2

Build the MQX Library

a. Browse to mgx\configitwrmcf52259 ATHEROS_WIFI\cwcf72 and click on project file (.mcp).
This will open the project in Code-warrior.
b. Click make to build the libraries.

File Edit View Search Project Debug MQX RTCS Tools ProcessorExpert Device Initialization Window Help
AasgiovxhaAA s s B2RA
=l
build_twrmcf52259_libs ATHEROS_WIF . mcp I
[ # aLLuss B ¥ 5 -
File I Link. Drderl Targetsl
¢ | File | Code | Data |4 IE
B bsp_twrmcfG2259_ATHER. . néa nfa = ul-
B psp_twimncfS2259_ATHER. . n'a nia = ul
BB mifs_twrmctS2259.mop nia nia = B Building build twrmcf52258 libs ATHEROS WIFL,
BB s twimcfB2269 mep n‘a nia = = e -1 — = @
BB usb_hdk_twrmef52259.mep e nia = = Proiect:|psp_twrmcf52259_ATHE... Talget:|Debug RegaBl Stop | ‘
B usb_ddk_bermncfS2289.mep n'a nia * =
B shell_bwmcfS2259.mop nia nia * =l File Tazk File Count Line Count
psp_tinm.c Compiling... 430 1]
Tatals: 4595 95913065
7 files 1] 1]
< m | »
|

Compile the Demo Application

a. Browse to the corresponding cwcf72 folder in the demo and double-click on the project file
(.mcp). This will open the project in Code-warrior environment.

b. Click “make”.

Open Tools->Flash Programmer. Uncheck “Use Current Settings” check box.

d. Inthe Flash Programmer window, ensure that Connection is set to “Coldfire v2-v4 JM60
OSBDM”

e. Click “Load Settings” and select MCF52259 INTDLASH.xml

o
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H:] Flash Programmer
Flazh Programmer Target Configuration

T arget Configuration
Flazh Configuration

Eraze / Blank Check Default Project: web_kvac hwrmcf52259. mep
Program / Werify
Checksum Default Target: Int Flash Debug

[~ Use Custom 5ettings

Processar Family: I.-'-\II ;I

Target Proceszor; |52259 ;I Connectian: IEu:uldFire wa-ed JMED OSEDM ;I

¥ Use Target Initialization

[Imtialization File of Default Target used when 'Usze Custom Settings’ unchecked.] B |

— Target Rakd kMemary Buffer Options

Target Memary Buffer Address: On |2E“:“:“:IDDD ¥ Enable Lagging
Target Memary Buffer Size: O IE'E“:“:IBDDD [ Werify Target Memary writes

Show Log I Load Settings. . I Save Settings... | Cloze |

f. Click on Erase/Blank Check tab. Click Erase.

ﬁ Flash Programmer

Eraze / Blank Check Flazh

Flazh Frogrammer
Target Caorfiguration

Flazh Configuration v all Sectors [ Erasze Sectors |ndividually
Blank Ches

Program / Werify

Checksum 00000000 00A0OFFF

000071000 0oaoFFFE
00002000 0000ZFFF
00002000 Q0003FFF
00004000 00O04FFF
Q0005000 Q000SFFF
Q000s000 Q000EFFF
Qo007 000 0oo07FFF
Q0002000 Q000SFFF
00003000 00o0sFFF
00004000 0000AFFF
Q0ooeQ00 QO00BFFF
0000co00 A000CFFF
QoooDo00 00000 FFF
0000EDO0 O000EFFF
0000FO00 0DOOFFFF
00010000 00010FFF
0o0171000 0oo11FFF
0001 2000 0001 2FFF
00013000 00013FFF
00014000 00014FFF S

Status: Details |

Eraze Blark Check |

m. | »

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 7 of 21
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g. Click Program/Verify tab. Click Program, this will download the image to the tower platform. A
reset on the microcontroller will initialize the demo application.

ﬁ Flash Programmer

Flazh Programmer
Target Configuration

Fragram / Wenfy Flash

Flazh Configuration [ Use Selected File
Eraze / Blank Check
Pragram / \erity Dutput File of Default Project-Target used when Use Selected File' unchecked.
haa [Output File of Default Praject-Target used when 'Use Selected File' unchecked.) e
File: Type: I.l'-\uh:u Detect j
[T Restrict Address Range [ Apply Address Offset

Skark: 0 IDDDDDDDD
- Offset: O (00000000
End: 0% IDDD?HH

Flazh B ase Address: (00000000

Status I [retailz |

Program | Werify

Shaw Lag I Load Settings... | Save Settings. .. I Claze |

5.2 TWR-K60N512 with IAR Embedded Workbench

Build the MQX Library
a. Open IAR Embedded workbench IDE.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 8 of 21
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Fies n B

IAR Information Center for ARM

Hereyou will find 3 the nfdrmation you need (o pet started . tulonals, exampls
OGRS, Lscei And TRINTHOLE Pukes: ammnm,mm :

{ |
!:‘._.A H # | S0 | el
- e e —
CETTING STARTED usRcunes EXAMPML PROECTS INTEGRATID RTOSa>
Daideline Sor mtsng v Carplete product Baarcis
PO TR MOE NG s FOF AWEITL BR3 eaTEle
Ve cerpeiing. briing. foreat ghves you ol e avdvnce pet phetely for projech for (e degreted
anz it e 15eatc Jen oo 402 ATOS and réssianse
"!"“',"‘""""1 nd-nwkv-& whesom.
", ¥
Kiics B3 heoa | P
_—_ —_— —— —
TUTORALY SIPPORT RELEASE NOTES Wy Pagos
Tiesdah 3 rake pou For Quasions 350ut fow Faad aboet T st e pou SN Sowrdoes
lorvitor wis the 102 t2 uos your LAN pradet. Sestama. resy device Fradent uodety.
202 e feataw of the PSR 8 pestheve, o SOt A0d Teg Tomtin MCARBgE Lmnant and
BN Y fabegge g sppent e wlewse notes. cueiect FfoRasze, ang
T ek poun SUA wada

b. Click File->Open->Workspace
c. Browse to mgx\config\twrf60n512_ATHEROS_W!IFN\iar folder and select “build_libs”.

File Edit View Project Simulator Tools Window Help

DEHE & ) BR|o | AV P AR VRS

<« twrk60n512 ATHEROS WIFL » iar » v Sean:h | Searchiar P }

| Orgamzev New folder = v @ x

¢ Favorites £ Neme Date modified Type

B Desktop 1. settings 331/2011614PM  File folder
|18 Downloads | 4 build libs 3/31/20116:14PM  IARIDE W,
‘% Recent Places

[ Libraries
Documents
o Music
|| Pictures
B Videos

o <
File name: build_libs

d. Click View->workspace. You will now see all library projects in the workspace pane.
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SIS

T Y R
D & 2R = bd .
x

Files £o
8 Bl build_libs
bsp_twrk... v
psp_twrkB... v
ries_twrkB0... v
mfs_twrkB0.. v
shell_twrkB.. v
ush_ddk_t.. v
Fush_hdk_t.. v

I Overview bsp_twikBOn512] ¢ |,

e. Select first project in workspace, click Project->make or press F7.
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ST
File Edit View [Project] Simulator Tools Window Help
DS W@ AdFies. -4y Ss=FEe»
; Add Group... I
[bsp_twik60n512_41  Import File List..
Files Edit Configurations...
B Ebuild_libs e
psp_twr Create New Project...
:tni:m Add Existing Project...
shell_ Options... Alt+F7
ush_dd
F ush_hd} Source Code Control »
. Make Z
~ Compile Ctrl+F7
Rebuild All
Clean
Batch build... F8
Stop Build Ctrl+Break
Download and Debug Ctrl+D
Debug without Downloading
Make & Restart Debugger Ctrl+R
Restart Debugger Ctrl+Shift+R
I Overview bsp_ty Dawilond >
= Log

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 11 of 21
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Fi d‘tt V -. u T p

éD@Qﬁ@M%awwﬂ A4y Ee P EH
Workspace |
|[bsp_ twikB0n512_ATHEROS_ Wi v]

Files &n o
8 @ build_libs

@ l--
—& (P mfs_twrkB0...
—= () psp_twrké...

rtcs_twrkB0...
shell_twrkb...
(Fushb_ddk_t...
ush_hdk_t...

< <KL

I Overview  bsp_twikB0n512, ql;

Messages

storerecall.c
A\ Warning[Pe009]: nested comment is not allowed
tfs.c
ush_mkBD.c
vectors.c
Building library
Performing Post-Build Action

Total number of errors: 0
Total number of warnings: 11

f. Repeat for all libraries.

Compile the Demo Application

a. To build the demo project, in the IDE click on Project->Add Existing Project.
b. Browse to mgx/demo/web_hvac_wifi/iar and select hvac_twr60n512.ewp and click open.

(Note: the screenshots that follow incorrectly show the “hvac_wifi”, the next revision of this
document will correct show the “web_hvac_wifi”. Please ensure that you are using the
web_hvac_wifi)

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 12 of 21



R 4

Z “freescale"

semiconductor

Y& AR Embedded Workbench IDE

File Edit View Project Simulator Tools Window Help - - -
DeHd S ¢ 2R | YRR PERGEUERS| D D
Workspace x

[ bsp_twik60n512_ATHEROS Wi ~|

Files & m Ry L 3 =
& @build_libs G@ oy hraowWi ) Tty ol Saarctis
- ,vl & emo vac_wifi » iar v | > | | earch iar ,o]
 mfs_twrkB0... v -
= Organize ¥ New folder 2EE
D psp_twrks.. v 9 § 0l @
rtes_twrkB0... v * Name Date modified Type
shell_twrkb.. v B Libraiies
Fush_ddk_t.. v B 1 settings 3/31/20116:12PM  Filefolder
ocuments : 5
Fush_hdk_t.. v P s | ] hvac_twrk60n512.ewp 3/31/20116:12PM  EWP File
usIc
|&=] Pictures
‘ Videos _
+& Homegroup
/% Computer
&L, Local Disk (C:)
| Overview bsp_twkBO0nS12/ ¢ [+ - Vista (D) | = , :

x

Messages File name: hvac_twrk60n512.ewp ~ | Project Files (*.ewp)

)

storerecall.c

&Warning[PelJl]Q]:nestedcomn l Y Iv] [

Cancel ]

tfs.c

ush_mkE0.c
vectors.c

c. This will add the demo project to existing workspace.

d. Select the demo project in workspace, click Project->make or press F7. Once the project is built

successfully, next step is download to the flash.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide
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e Project Tools Window Help
D@ & BB o vy
hvac_twikB0n512 - Int Flash Deb v
Files b s
8 Blbuild_libs

—& (P hsp_twrkb... v

@ 5--
— ' mfs_twrkB0...
—& (P psp_twrkb... v
rtcs_twrkB0... v
shell_twrk6... v

v

v

ush_ddk_t..
ush_hdk_t...

Image download

a. First we need to set up the Debugger. Right click on demo project in the workspace and click
“Options”

b. In Category, select Debugger. Ensure the following-
e in Setup tab, PE Micro is selected as Driver.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 14 of 21
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=J
fn B
brar...
ibrar...
Libr... :
ibra... Coceoy  Factory Settings
) General Options
ost C/C++ Compiler
Assembler
Output Converter Setup | Download | Images | Extra Options | Plugins |
Custom Build
Build Actions Driver Runto
oL | PE micro - main
Simulator Setup macros
Angel Use macro file(s)
GDB Server —
IAR ROM-monitor I ] -]
J-Link/]-Trace I J D
7_‘- mfs_twrlm gL Ste!lans 202
— Macagor Device description file
PE micro ‘ ’ -
25 RDI [7] Overide defautt
sk.c ST-LINK |STOOLKIT_DIRS\CONFIG\debugger\Freescale\iokG(boou.ddf ] EJ
‘ask.c Third-Par ty Driver
Pe188]: enumerated ty
ses.c I oK I [ Cancel ]

LEMNWETD At

¢ In Download tab, “Use Flash Loader” check box is checked.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 15 of 21
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Category:

[ Factomy Settings

General Options
C/C++ Compiler
Assembler
Output Converter Setup | Download |kﬂ3§‘$ I Exdra Options | Fiugns|
Custom Build =
Build Actions A
Linker Verfy download

Suppress download

Simulator

Angel Use flash loader(s)
GOE Server Ovemde default board file

IAR ROM-manitor |STDDLKIT_DIHS"-J:Dnfig"-ﬂashlu:nader"-.Freesu:aIe"-.FIasI’|| |
Jink/1-Trace

TI Stellaris FTDI Edit ...
Macraigor ‘—|
— PE micro I
RDI

ST-LIMNK
ThirdParty Driver

] ] [ Cancel

¢ In Plugins tab, MQX checkbox is checked.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 16 of 21
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Category: [ Factory Settings
General Options
C/C++ Compiler
Assembler
Output Converter | | | Setup | Download | Images | Extra Options | Plugins |
Custom Build .
Build Actions Selectmugmtobmi:—
Linker -
FICHXTINY 3
Simulator SEGGER emb0OS 3
Angel MaX
GDB Server FreeRTOS and OpenRTOS
IAR ROM-monitor []Power Pac RTOS
JLink/J-Trace [FIRTXC Quadros b
TI Stellaris FTDI Description: RTOS awareness for CMX.
‘ Macraigor :
7 :i;mcro Location: C:\Program Files (x86)\IAR Systems\Embedded Workbenct B
STLINK Originator: IAR Systems
Third-Party Driver Version: 6.105.52324
ty

[ 0K ][ Cancel ]

e In category, select PE micro. Ensure that P&E Hardware Interface type is set to OSJtag.
e Now click Project->Download->Download Active Application
OR
click Project->Download->Download File...
Here you can specify the Download image.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 17 of 21
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File Edit View Project Tools Window Help

D U@ &4 BR[o | ~ /Y %0 D P [0

|Int Flash Debug -
Files o oy
=i hvac_twik6 [ v | |
[IMFS Librar...

CIMQX Librar...
[JRTCS Libr...

[ Shell Libra...
[JSource

[JUSB Host ...

1 Output

I hvac_twikB0n512 mfs_twd

This will download the image. The board is now ready for use after a reset.

6 Running the Demo

The demo can be configured through the demo ‘source.h’ file. An example is ‘hvac.h’ under the
projects source directory. The demo file from Atheros is set up to work with a pre-defined
variables but if you can change the settings through the definitions in the .h file. An example of
things to change is IP address, Security type and keys, etc. Any changes need to be saved and the
system needs to be rebuilt (MAKE) and reloaded on the hardware.

The default parameters are-

DEMOCFG_SSID "atheros_demo"
Gateway address- 192.168.1.2
Local Address — 192.168.1.90

No Security.

To access the system place the PC on the same subnet as the tower system and input IP address of
the tower system into the internet browser “192.168.1.90” to display the Web Page for the Tower
System. You can now navigate to the HVAC DEMO via the right navigation bar on the welcome

page.

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 18 of 21
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Freescale MQX ™ Web Server
Network Status... This page is running off the internal flash memory of the MCF5225X processor. Please insert the included USB
mass storage device into your board and refresh this page to view more information on the MCF5225X family.
System Run Time (RTC)
(CF5225x Family MCF5225X Family
M 22 The MCF5225x family consists of highly integrated devices with on-chip USB, Ethernet, CAN and encryption
functions. The MCF5225x family is based on a 32-bit ColdFire® core with up to 80 MHz core frequency, 512
KB flash and 64 KB SRAM. The external bus interface provides flexibility to add additional memory or simple
peripherals. These and other features make the MCF5225x devices ideal for industry and health care
Atheros applications that require a broad range of connectivity peripherals and high performance.

MQX Software Solutions

The MQX Real-time Operating System provides real-time performance within a small, configurable footprint.
The MQX RTOS Is designed to allow you to configure and balance code size with performance requirements.
The easy-to-use MQX API and out-of-box experience ensures first-time RTOS users can start developing their
application on the day you install the software but is powerful enough for experienced OS developers easily
migrate legacy application code to an MQX-based platform.

MCF5225x Family S
One-stop-shop connectivity MCU with USB, Ethemet, CAN, featuring MQX software solutions

® Freescale Semiconductor, Inc. 2004 - 2008. All Rights Reserved

ano Freescale MQX Webserver
| < | » | [+ |@hitp/192.168.1.90/ hvachiml ¢ | (ar Google

-

= “freescale"
somiconducion

Webserver Home HVAC Demo - Change Settings
HVAG Demo...
Network Status... Mode: Auto
System Run Time (ATC) Desired Temp: 20.0 °C
MCF5225x Family Actual Temp: 20.0 °C

Fan Mode: auto

Fan: off
Furnance: off
AC: off

On the Tower System the LEDs represent the current state of the HVAC:
LED1 represents Fan ON/OFF

TWRWIFIAR4100LAB TWR-WIFI-G1011MIAR4100 Lab Guide Page 19 of 21
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LED2 represents Furnace ON/OFF
LED3 represents A/C ON/OFF
The Push button Switches change the Temperature and are configured differently on the ColdFire and
Kinetis platforms.
ColdFire SW1 Temperature Up
SW3 Temperature Down
Kinetis - SW1 Temperature Up
SW2 Temperature Down

Use the Change Settings page to control the fan (LED 1). The fan on option forces the fan to be on,
while fan auto puts the fan into automatic mode so that the fan is only on when the HVAC needs to
change temperature.

ano Freescale MQX Webserver

[ 4] » ||+ [@nitp://192.168.1.90/hvac_input.htmi ¢ | (Q- Google )

(77 i Twitter / Home Facebook DealCatcher: Amazon.com..Ds & more Slickdeals: BRADS DEALS Applelnsider...nd Analysis »
freescale”

Webserver Home

Change HVAC Settings
HVAC Demo...

—— Desired Temperature:

System Run Time (RTC)
MCF5225x Family Temperature unit:

@°c

Q°F

HVAC Mode:
® Heat
(O Cool

Qoff

Fan Mode:
@ Auto
O0n

o
et

Since the default settings for the demo have the “desired temp” and “actual temp” at 20°C, either the
furnace or the AC do not need to be turned on.

Turn the fan on to automatic mode, and put the HVAC into heat mode using the Change Settings page.
This turns on the furnace, and with the fan in automatic mode, the fan will only turn on when the
desired temperature is higher than the actual temperature.

On the Coldfire Platform we will use the User configured SW 1 and SW3 however when running on the
Kinetis platform we will be replacing SW3 with SW2 and will use SW1 and SW2 for the demo.

Push buttons SW1 and SW3 (Kinetis SW2) on the board are used to change the desired temperature.
SW1 increases the desired temp and SW3 (Kinetis SW2) lowers it. Press SW1 once and see the
temperature change on the Desired Temperature change on the Web page.
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Press SW1 again, to see that the furnace has turned on and the fan has automatically turned on. The
furnace and fan LEDs should be on to indicate this status.

Use SW3 (Kinetis SW2) to lower the desired temp such that the furnace and the fan turn off. You can
also use the Desired Temperature Window on the Change Settings page to change the desired
temperature.

Experiment on your own with changing temperature and fan settings.

7 Refrences

¢ TWR-WIiFI-AR4100 Web Page
o http://www.freescale.com/webapp/sps/site/prod summary.jsp?code=TWR-WIFI-AR4100

o TWR-MCF5225X-KIT: Tower System Coldfire® V2 MCF5225X Connectivity Module
o http://www.freescale.com/webapp/sps/site/prod summary.jsp?code=TWR-MCF5225X

¢ TWR-K60N512-KIT: Development Kit for Kinetis K60
o http://www.freescale.com/webapp/sps/site/prod summary.jsp?code=TWR-K60N512-KIT
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