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STM32W-SK and STM32W-EXT starter and extension kits
for STM32W108xx 

Introduction
The STM32W-SK and STM32W-EXT starter and extension kits are easy to use tools for the 
STM32W108xx microcontrollers. This family of microcontrollers integrates a 32-bit ARM® 
Cortex™-M3 microprocessor and a 2.4 GHz, IEEE 802.15.4-compliant transceiver. The kits 
demonstrate how effectively the STM32W108xx can be used in real IEEE 802.15.4 
applications. They are suitable for different types of wireless network scenarios such as:

● Mesh networks (based on the ZigBee PRO protocol stack) typically used in home 
automation and smart energy applications.

● Remote control and target networks (based on the ZigBee RF4CE protocol stack) used 
for driving consumer devices such as TVs, set-top boxes, etc.

● Point to point networks (based on a Simplified MAC library) used to address a basic 
IEEE 802.15.4 communication. This configuration enables customers to develop any 
protocol stack of their choice.

The STM32W108xx kits provide demonstration applications and documentation which serve 
as a reference for creating your own applications and re-programming the STM32W108xx 
microcontroller. You can run the STM32W108xx kits in several ways (building mesh 
networks, remote control/target and point-to-point applications), using the dedicated 
software libraries (ZigBee PRO, ZigBee RF4CE, and Simplified MAC), as well as a third-
party IDE and C compiler (IAR).

Moreover, the STM32W108xx kits provide a set of HAL APIs which allow you to use the kit 
platform capabilities such as LEDs and serial communication channels (virtual COM 
through USB).

In this manual, you can find information about:

● The STM32W108xx kits components

● How to install the related hardware, software and documentation trees

● How to run the preprogrammed demonstration applications.

www.st.com

http://www.st.com
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1 Getting started

This section provides a complete description of the STM32W-SK and STM32W-EXT kit’s 
hardware and software.

There are two types of STM32W108xx kit:

● The starter kit (order code: STM32W108B-SK)

● The extension kit (order code: STM32W108B-KEXT)

1.1 Kit description

1.1.1 Hardware

STM32W-SK

The STM32W108xx starter kit package contains the following hardware components: 

● Two STM32W108 application boards (MB851) 

● One STM32W108 extension board (MB850)

● One Raisonance STM32-Primer2 tool (STM3210E-PRIMER)

● One J-Link Lite JTAG Flash programmer and debugger

● One mini USB cable

● Four AAA batteries

Figure 1. STM32W-SK starter kit

STM32W-EXT

The extension kit package contains four STM32W108 application boards (MB851).

Network Analyzer (Perytons)

J-Link Lite +
IAR compiler

MB850 
extension board

+
STM32-Primer2

MB851 application board x2
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Figure 2. STM32W-EXT extension kit

Note: 1 For documentation concerning the STM32-Primer2 tool, refer to the related user manual on 
the http://www.stm32circle.com website.

2 For information concerning the STM32W108xx MB850 and MB851 boards, refer to the 
documentation with each available software and documentation tree installer file (see 
Section 1.2: Software libraries and demonstration applications).

1.1.2 Software

STM32W-SK

The starter kit package contains the following software components:

● One CD-ROM including PerytonsTM network analyzer (V3.05 or later).

● One CD-ROM including the IARTM Limited 30-days Evaluation Compiler 5.40.7 or later.

● One CD-ROM including the RaisonanceTM Development Suite for the STM32-Primer2.

STM32W-EXT

No CDs are delivered with the extension kit package.

1.1.3 Documentation

The starter kit package STM32W-SK contains the following documentation components: 

● STM32W108 starter kit welcome letter which briefly describes the kits targets and 
components.

● Raisonance STM32-Primer2 welcome letter.

The extension kit package STM32W-EXT contains an STM32W108 extension kit welcome 
letter which briefly describes the kits targets and components.

MB851 application board x4

http://www.stm32circle.com/
http://www.stm32circle.com/
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1.2 Software libraries and demonstration applications
The following installer files are available on the http://www.st.com/mcu/, STM32W section:

● EmberZNet-4.0.2.0-STM32W108: installer file which provides the EmberZNet™ 4.0.2 
GA software libraries and demonstration applications targeting the mesh network 
scenarios based on the ZigBee PRO protocol stack.

● ST ZigBee RF4CE-1.0.0.0-STM32W108: installer file which provides the STM32W108 
ZigBee RF4CE software library and demonstration applications for controlling an 
RF4CE compliant TV using an RF4CE compliant remote control.

● ST Simple MAC-1.0.0.0-STM32W108: installer file which provides the STM32W108 
Simple MAC software library and demonstration applications targeting point-to-point 
communication scenarios based on the IEEE 802.15.4 protocol. 

For a detailed description of each software and documentation tree, refer to the related 
documentation (starting from the HTML index file, that comes with each installer file).

Note: Each installer file also provides a set of prebuilt binary images (applications and utilities).

http://www.st.com/mcu/
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1.3 Kit setup

1.3.1 Powering on the boards

The MB851 application board can be powered as follows: 

● Via batteries (fit 1-2 on the P2 jumper) 

● Via USB or JTAG (fit 5-6 on the P2 jumper) 

Note: 1 The jumper position 3-4 is reserved for internal usage.

2 To enable the MB851 board temperature sensor, MEMS and infrared, fit the jumper JP1.

The MB850 extension board has been designed as an IEEE 802.15.4 application-specific 
daughter-board. It must be connected to the STM32-Primer2 extension connector to be 
powered through the STM32-Primer2. The MB850 should be connected with the 
STM32W108 visible. 

1.3.2 Installing the FTDI USB drive

In order to use the serial communication channel on the MB851 board, a driver for the FTDI 
USB<->Serial converter must be installed. This driver can be downloaded from the FTDI 
website: http://www.ftdichip.com/Drivers/VCP.htm.

1.3.3 Setting up the application serial communication channel 

To get full access to all the available commands, some demonstration applications may 
require that the MB851 board is interfaced with the user through a serial communication 
channel (virtual COM through USB). To set a serial communication channel for the MB851 
board, follow these steps:

1. Fit the MB851 jumper P2 on position 5-6 (power via USB).

2. Connect a mini USB cable to the MB851 mini USB connector and to a PC USB port.

3. Right-click on My Computer, select Manage, Device Manager, and open Ports (COM 
& LPT) to display the related USB COMx port.

4. Open a hyper terminal on the corresponding USB virtual COMx port with the following 
configuration:

– Bit rate: 115200

– Data bits: 8

– Parity: None

– Stop bits: 1

– Flow control: None

The STM32-Primer2 and MB850 demonstration applications use the STM32-Primer2 
resources (LCD, joystick with button, touch screen display) as I/O communication channels.
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2 Running the STM32W108xx kits 

STM32W-SK

In the STM32W-SK starter kit, the following applications are preprogrammed: 

● One EmberZNet ZigBee PRO sink firmware (MB850 board labeled as “Sink”)

● Three CircleOs applications preloaded in the STM32-Primer2:

– ZigBee PRO sink application

– ZigBee RF4CE RC application

– Simple MAC sun sample application 

● One EmberZNet ZigBee PRO sensor firmware (MB851 board labeled as “Sensor”) 

● One Perytons capture firmware (MB851 board labeled as “Analyzer”)

This allows you to immediately run the ZigBee PRO sink, sensor demonstration 
applications, just by selecting the sink application on the STM32-Primer2 (see Section 2.2: 
Sink, sensor mesh network (based on ZigBee PRO) for more details). You can also start a 
packet capture session using the Perytons analyzer (see Section 3.2: Network analyzer for 
more details).

STM32W-EXT

In the STM32W-EXT extension kit, all four boards are preprogrammed with EmberZNet 
ZigBee PRO sensor firmware (MB851 board labeled as “Sensor”). 

Using these boards, you can extend the sink, sensor mesh network with other four sensors 
nodes.

2.1 Installing the STM32W108xx kit software tree
To install the specific kit software and documentation tree, download the related installer file 
from http://www.st.com/mcu/, STM32W section. Then start the installation process on your 
destination folder.

2.2 Sink, sensor mesh network (based on ZigBee PRO)
This section shows how to set up a mesh network with a ‘sink’ node which collects 
information that come from several ‘sensor’ nodes.

2.2.1 Run preloaded sink appl. on STM32-Primer2, MB850 platforms

The STM32-Primer2 tool is delivered with the sink application preloaded. This application 
automatically configures the connected MB850 extension board with the related ZigBee 
PRO sink application. 

To run the sink application on the STM32 Primer2 and MB850 boards, follow these steps:

1. Connect the MB850 to the extension connector of the STM32-Primer2 tool.

2. Power on your STM32-Primer2.

3. Press the joystick button to launch the main menu and select Applic.->ZP SINK.

http://www.st.com/mcu/
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If everything is done properly, you get an LCD screen showing a light blue box in the center 
(see Figure 3). This box represents the sink node (a ZigBee PRO network has been 
created).

Figure 3. STM32-Primer2 sink node

4. To access the application main menu, press the button again. This is the first level 
option list. Options can be classified in two categories:

– Options that give information about the sink node (node address, security key, 
address table, child table …).

– Options that execute specific commands (send custom messages, permit join, 
leave network, reset, quit).

2.2.2 Run preloaded sensor application on the MB851 board

To run the sensor application on the starter kit MB851 board, follow these steps:

1. Power on the MB851 board already preloaded with the sensor application (labeled as 
sensor).

2. If you want to access to the full set of the available commands on the sensor node, you 
have to set up the related serial communication channel, following the steps described 
in Section 1.3.3: Setting up the application serial communication channel.

3. Once the sensor application is running, type ’?’ on the related hyperterminal to get the 
list of available supported commands.

Note: A prebuilt sensor binary image is also available. To download it, just use the stm32w_flasher 
utility (refer to Section 3.1: stm32w_flasher utility).

2.2.3 Setup a sink, sensor mesh network 

To set up a sink, sensor mesh network, from the STM32-Primer2 sink main menu, select 
Permit join and press the S1 button on the MB851 board sensor.

Once the sensor is joined to the network formed by the sink, the sensor node is displayed on 
the STM32-Primer2 LCD as a green box with the related 2-byte short address underneath. 
Furthermore, the MB851 LEDs start blinking.

Figure 4. Sensor joined to the sink
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When the sensor sends data to the sink, a blue line connecting the transmitting sensor to 
the sink is displayed on the screen. The unicast data sent by the MB851 sensor node is a 
temperature value coming from its temperature sensor.

Figure 5. Sensor sends unicast data to the sink

This allows you to identify which sensor is transmitting data if there is more than one sensor 
(up to 5 supported by the STM32-Primer2 sink application).

Note: The unicast data sent by the sleepy or mobile sensors are 2 bytes random data.

Figure 6. Sink + 5 sensors (including sleepy, mobile sensors)

The following table groups the symbols appearing on the STM32-Primer2’s LCD screen and 
the associated events:

          

Table 1. Definition of LCD screen symbols (ZigBee PRO sink application) 

Symbol Associated event

Blue line connecting two nodes Unicast data transmission (see Figure 5)

5 orange lines arranged in a star-like shape Multicast data transmission (see Figure 7)

! Error condition (see Figure 8)

D Network down (see Figure 9)

Gray box Sleepy sensor 

Purple box Mobile sensor



UM0894 Running the STM32W108xx kits

Doc ID 16999 Rev 2 13/21

Figure 7. Sink sends an advertise (multicast message)

Figure 8. Network error on sink node 

Figure 9. Network down

Note: For further information about the STM32-Primer2, MB850 sink application and related 
limitations, refer to the installer file documentation.

2.3 Remote control and virtual TV (based on RF4CE library)
This section shows how to control a ZigBee RF4CE-compliant TV target using an RF4CE-
compliant remote control. The demonstration application is run using the STM32-Primer2 
and MB850 as a remote control and a PC applet for emulating a TV on your PC.

The RF4CETV PC applet implements a virtual TV supporting the following features:

● 12 channels, playing video from files

● Volume control

● Mute

● Channel change

● Play/Pause

● Pair button

● Device information
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2.3.1 Run the remote control (RC) and virtual TV applications

The STM32-Primer2 tool provided with the STM32W-SK starter kit is delivered with the RC 
application. This application automatically configures the connected MB850 extension board 
with the related ZigBee RF4CE RC application. 

The MB851 board is automatically configured when launching the RF4CETV PC applet.

To run the RC and TV applications on the STM32 Primer2, MB850 and MB851 platforms, 
the following steps are required:

1. Connect the MB850 to the extension connector of the STM32-Primer2 tool.

2. Power on your STM32-Primer2.

3. Press the joystick button to launch the Main Menu and select Applic.->RF4CE RC.

If everything is properly done, the LCD screen displays a set of RF4CE RC commands.

4. Connect the MB851 board to the PC using a mini USB cable with P2 fitted in position 5-
6 (power from USB). A virtual COM port should appear in the Windows Device 
Manager.

5. From Windows, launch the RF4CETV.exe PC applet. A PC applet GUI appears.

6. Select the serial port matching the port assigned by the Windows Device Manager. If 
the firmware on the MB851 board is not present, the application uploads the firmware 
through the serial port. Wait until the LED D1 is on.

7. Push the button to start pairing with the RF4CE remote control. LED D1 starts 
blinking quickly when the node is ready for pairing (for 30 sec.).

8. On your STM32-Primer2, use the joystick to scroll between button pages until you find 
the button . Push the button to start pairing with the MB851 board.

If everything is properly done, a message on your STM32-Primer2 screen and in the 
RF4CETV applet informs you that the pairing process has been successful.

Figure 10. RF4CETV PC applet
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2.3.2 Use the remote control (RC) and virtual TV applications

To send an RC command to the virtual TV, push the associated RC symbol on the STM32-
Primer2 touch sensing screen.

Figure 11. RF4CE RC application driving the ST Virtual TV PC applet

Note: For further information about the ST RF4CE demonstration applications, refer to the 
STM32W108xx ZigBee RF4CE library user manual (UM0909).

2.4 Basic star network (based on Simple MAC library)
This section shows how to set up a star network supporting parent and child roles (called 
respectively; sun and planet).

2.4.1 Run preloaded sample appl. on STM32-Primer2, MB850 platforms

The STM32-Primer2 tool provided with the STM32W-SK starter kit is delivered with a 
sample application (sun image). This application automatically configures the connected 
MB850 extension board with the related sample application.

To run the sample application on the STM32-Primer2, MB850 platforms, follow these steps:

1. Connect the MB850 to the extension connector of the STM32-Primer2 tool.

2. Power on your STM32-Primer2.

3. Press the joystick button to launch the main menu and select Applic.->SM SUN.  
If everything is done properly, you get an LCD screen showing a light blue box in the 
center. This blue box represents the sun node (a network has been created).

Figure 12. STM32-Primer2 sun node

STM32-Primer2 RC ST Virtual TV
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4. Press the button again to access the application main menu. This is the first level 
option list. Options can be classified in two categories:

– Options that provide information about the sun parameters (node information, 
planets list)

– Options that execute actions (leave network, quit)

Note: For further information about the STM32-Primer2, MB850 sun application and related 
limitations, refer to the documentation that comes with the installer file.

2.4.2 Run the prebuilt sample planet application on the MB851 board

To download and run the prebuilt sample planet application on an MB851 board, use the 
stm32w_flasher utility with the prebuilt sample_planet.s37 binary file. 

Refer to Section 3.1: stm32w_flasher utility for more details.

2.4.3 Setup a star network 

On the planet node, press button S1 to join the network formed by the STM32-Primer2 sun 
node. Once joined, the planet LED D3 turns on and the planet node is displayed on the 
STM32-Primer2’s LCD (as a green box with the related 2-byte short address underneath). 

Figure 13. Planet device joined to the network

When a planet device sends data to the sun device (at periodic rate), a blue line connecting 
the transmitting planet to the sun is displayed on the screen as well as the sent MB851 
VDD_PADS value (in mV).

Figure 14. Planet sends data to the sun

This identifies which planet is in transmission mode if there is more than one planet device 
(up to 5 supported by the STM32-Primer2 sun application). 
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Figure 15. Sun node with 5 planets

Figure 16. Network down 

The following table summarizes the symbols appearing on the LCD screen and the 
associated events.

          

Note: For further information about the Simple MAC sample application, refer to the installer file 
documentation (in particular, STM32W108xx Simple MAC user manual - UM0893).

Table 2. Definition of LCD screen symbols (Simple MAC sample application)

Symbol Associated event

Blue line connecting planet to sun Planet sends data to the sun (see Figure 14)

D Network down (see Figure 16)
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3 STM32W108xx kits utilities and software tools

3.1 stm32w_flasher utility
The stm32w_flasher utility allows you to download a binary file into the STM32W108xx 
MB851 board. This utility comes with each software installer file. To download a binary 
image, follow these steps:

1. Fit the MB851 jumper P2 on position 5-6 (power via USB).

2. Connect a mini USB cable to the MB851 mini USB connector and to a PC USB port.

3. Using the mouse, right-click on My Computer, select Manage, Device Manager, and 
open Ports (COM & LPT) to display the related USB COMx port 

4. Open an DOS Window on your PC

5. Go to the utilities folder which comes after the installation process

6. Type the following command: stm32w_flasher –p <COMx> -r –f <file_name.bin/.s37>

where COMx is the virtual COM related to the connected MB851 board, and 
file_name.bin/.s37 is the application image to be downloaded.

Note: You can also use the stm32w_flasher utility through the JTAG programmer:

1. Fit the MB851 jumper P2 on position 5-6 (power via JTAG). 
2. Plug the JTAG programmer to a PC USB port and to the board JTAG connector P4. 
3. Open an DOS Window on your PC. 
4. Go to the folder where the stm32w_flasher is located (tool or utility folder). 
5. Type the following command: stm32w_flasher -f <file_name.bin/.s37> -r

3.2 Network analyzer

3.2.1 Perytons

To install the Perytons network analyzer, insert the related CD-ROM and follow the 
installation instructions. To use the Perytons network analyzer, follow these steps:

1. MB851 board labeled as "Analyzer“: fit jumper P2 on position 5-6 (power via USB) and 
connect to a PC USB port.

2. Open the Perytons tool (from Start, Programs).

3. For instructions about how to start a packet capture session refer to the documentation 
on the Perytons CD-ROM.

When a packet capture session is ongoing, the MB851 LEDs behave as follows:

● When data is sent to the PC LED D1 flashes for a short period.

● LED D3 is the heartbeat LED

A prebuilt analyzer binary image for Perytons is provided with each installer file.

3.2.2 Daintree

A binary image supporting the Daintree network analyzer is also available. No CD-ROM for 
Daintree is delivered with the STM32W108xx kits. For more information refer to 
http://www.daintree.net/.
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3.3 IAR Embedded Workbench® for ARM
To install the IAR Embedded Workbench® for ARM 5.40.7 or later, insert the related CD-
ROM and follow the installation instructions.

To build the binary image of all the available demonstration applications using the IAR tool, 
follow these steps:

1. Open the IAR tool.

2. From the File > Open > Workspace menu, open the *.eww IAR project related to the 
demonstration application you are going to address.

3. From the Project menu, select Rebuild All. A binary file is built under the project folder 
specified in Project > Options > General Options Category > Output menu > 
Executables/libraries item.

To download the built binary image on the MB851 board, follow these steps:

1. Connect the JTAG Flash programmer to the MB851 P4 connector and to a PC USB 
port (through an USB cable).

2. Power the MB851 application board through the JTAG: P2 jumper fitted on 5-6 position.

3. From the Project menu, select Download and Debug. The binary image is downloaded 
into the STM32W108xx Flash.

4. From the Project menu, select Stop Debugging. The application is ready to run.

Note: To use the J-Link Lite JTAG Flash programmer, you need to switch on the "power supply for 
target" feature. The first time you plug the J-Link Lite on a PC USB port, follow these steps 
(make sure that you have already installed the IAR Embedded Workbench 5.40.7 or later):

1. Open an DOS Window on your PC.

2. Type jlink.

3. Issue the command: power on perm.

3.4 Reflashing STM32-Primer2 using prebuilt primer2image.hex 
file
The primer2image.hex file contains the three CircleOs applications described in Chapter 2. 
This file is delivered with the installed package in the prebuilt folder. To download a new 
version of the primer2image.hex file or just recover from an accidental deletion, follow these 
steps:

1. Install Raisonance Ride 7.16 (or later) for ARM if not already installed on your PC (this 
toolset is available on www.stm32circle.com).

2. Go to the prebuilt folder.

3. Connect a mini USB cable to the STM32-Primer2 debug connector and a PC USB port.

4. Turn on the STM32-Primer2 by pushing its button.

5. Type the command: Cortex_pgm TSTM32F103VET6 E B.

6. Type the command: Cortex_pgm TSTM32F103VET6 Pprimer2image.hex S.
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4 List of acronyms

          

5 Revision history

Table 4. Document revision history

Table 3. List of acronyms used in the document

Term Meaning

API Application programming interfaces

CERC Consumer electronic remote control

GA General availability

HA Home automation

HAL Hardware abstraction layer

MAC Medium access control

RC Remote control

RF Radio frequency communication

SE Smart energy

USB Universal serial bus

Date Revision Changes

05-Feb-2010 1 Initial release.

21-Apr-2010 2

Modified software component versions in Section 1.1.2.
Modified installer files in Section 1.2.

Modified Parity to 1 in Section 1.3.3.

Modified Section 2.2.2, Section 2.2.3, Section 2.4.3.
Inserted Section 3.4.
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